Ask Your Question
0

Base (tables and forms) are read only and I want to edit.

asked 2018-04-13 01:44:56 +0100

SFOhio gravatar image

Base (tables and forms) are read only and I want to edit. The edit-data-icon amd add-record-icon are grayed out on form. Similar problems on when opening the table.

edit retag flag offensive close merge delete

Comments

Hello,

Your question lacks information such as LO version & OS. But more importantly where do you see a edit-data-icon amd add-record-icon on a form? The closest item is New Record on the Navigation control. Also, on viewing table data, there is an icon for Edit Data which is a toggle. On allows editing & off locks out entry. Additionally, what Database are you using?

Ratslinger gravatar imageRatslinger ( 2018-04-13 02:04:05 +0100 )edit

Sorry I'm using. Libre Office Base Version: 6.0.2.1 (x64) on Windows-10 pc I had two tables... on closing and reopenning the database one of the tables allows me to toggle the edit button. The other does not.

The form is built on a query from both. It does not allow me to add or edit the records/fields.

SFOhio gravatar imageSFOhio ( 2018-04-13 03:11:40 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-04-13 02:47:07 +0100

Ratslinger gravatar image

Hello,

Notwithstanding the missing information, it would appear you have created a Base .odb based on .csv file(s) or as selected, Text. These tables and forms cannot edit the data in this manner. Queries are also very limited. There is a somewhat better way to allow more flexibility. See answer by @pierre-yves samyn on this post -> [Base] Linked Table from CSV.

edit flag offensive delete link more

Comments

Sorry I'm using. Libre Office Base Version: 6.0.2.1 (x64) on Windows-10 pc I had two tables... on closing and reopenning the database one of the tables allows me to toggle the edit button. The other does not.

The form is built on a query from both. It does not allow me to add or edit the records/fields.

SFOhio gravatar imageSFOhio ( 2018-04-13 03:13:35 +0100 )edit

That CSV was a good hint... I remade the table (which was a lookup table). The edit button now toggles. I also added the key field that I didn't have before. It works now. Thanks for your help.

SFOhio gravatar imageSFOhio ( 2018-04-13 03:24:30 +0100 )edit

If this answers your question please tick the ✔ (upper left area of answer). It helps others to know there was an accepted answer.

Ratslinger gravatar imageRatslinger ( 2018-04-13 03:31:06 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-04-13 01:44:56 +0100

Seen: 662 times

Last updated: Apr 13 '18