Ask Your Question
0

How do I turn off the highlighting of active toolbar icons in 6.0.3?

asked 2018-04-14 17:16:10 +0100

andreas98 gravatar image

Some toolbar icons are highlighted in 6.0.3. For example, if an entry in a Calc cell is left-aligned, then the left-align icon will be highlighted in the toolbar. This is also an issue in Writer. I find this distracting. How do I turn off this feature?

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2018-04-15 11:51:58 +0100

Lupp gravatar image

updated 2018-04-15 12:15:58 +0100

The highlighting of the icon representing the alignment of the current cell (in Calc) or paragraph (otherwise) is used to show the current setting also in cases where the view doesn't do that clearly.

In a Writer text the typical case is a 'justified' alignment. As long as no complete line is filled it looks the same as 'Align Left'. (What good for? You may have such paragraphs outside the view when increasing the margins for your page style. Unwanted 'justified' will get in force by that probably. It's always better to know a bit too much than a bit too little.)

In Calc the info is essential. For cells there exists an additional value 'Default' for the horizontal-alignment attribute: 'Default' meaning "no explicit alignment" which is the default setting of the 'Default' cell style. It is mainly used to easily get the very relevant information whether a cell's content or result is 'Number' (displayed right aligned) or'Text' (displayed left aligned). This feature is also the reason for which you may want to switch off an existing explicit alignment. You can do so by clicking the highlighted alignment icon another time. Having set the alignment explicitly without need is one of the main reasons for misunderstandings about types getting contributors to forums to waste their time again and again with trying to get that cleared (in specific for dates often).

A general advice: Withstand the "less-information-is-better-ideology" promoted by MS. It's a way to hell.

edit flag offensive delete link more

Comments

Thank you for your answer. I agree that the formatting of a cell is important information, but I have always found it easy to check the formatting by right-clicking and choosing "Format Cells", which provides far more information. In Writer, I use Format>Paragraph, which provides full information. In any case, I have found a solution to my problem, which is to change my gtk theme (I'm using Linux) to a theme where the highlighting is not as bright. With the new theme it's less distracting.

andreas98 gravatar imageandreas98 ( 2018-04-15 15:28:50 +0100 )edit

My LibreOffice does, of course, not wear the clothes of yours. It is, however, inapprehensible for me how to be seriously distracted by a steadily highlighted icon. Blinking would be very different. I alo often use the 'Format Cells...' path or the formatting dialogue for paragraphs. In some specific cases a glance at an icon is much easier, imo. Think alone of the case that I want to decide whether two neighbouring cells have the same alignment set.

Lupp gravatar imageLupp ( 2018-04-15 17:23:27 +0100 )edit
0

answered 2018-04-15 07:00:13 +0100

pierre-yves samyn gravatar image

updated 2018-04-15 07:01:39 +0100

Hi

Since you are quoting precisely this example and the version number, I must begin by saying that this feature already existed in OpenOffice.org. This was not introduced in 6.0.3.

I do not know if there is an advanced setting to disable this feature.

The easiest way would be, of course, not to display the toolbars and, for example, to use only the sidebar that can be deployed only on demand.

Another solution that works in my environment (windows and 6.0.3.2 (x64)) is to switch to Notebookbar Contexual Groups display. In this mode the icons do not show the current state of the property.

That said, it is rather bug in my opinion and I do not know if it is a choice of developers and therefore, if it is sustainable.

Steps to reproduce:

  • ViewToolbar LayoutNotebookbar
  • If the menubar is not displayed, click the Menu button (top right in the tabs line) to enable the menubar
  • ViewNotebookbarContextual groups

Example with cursor in C3 (right aligned, italic)

image description

HTH - Regards

edit flag offensive delete link more

Comments

I wouldn't recommend the notebook bar. It was, imo, introduced due to the requests for that splendid "ribbon" that is poisonous itself: Make users lose any sense for structure and brainwash them to adapt the "what-should-I-click" mentality.
We will get the respective questions here if that succeeds.

Lupp gravatar imageLupp ( 2018-04-15 11:27:14 +0100 )edit

Thanks for your detailed response and for providing a work-around that works. Unfortunately I dislike the ribbon interface, and so this is not a solution that I will be using. Instead, I have changed my gtk theme to one where the highlighting is less distracting. Your comment that this is not a new feature caused me to ask myself why I hadn't noticed it before. It's because I had changed my gtk theme at the same time that I upgraded LibreOfffice. The new theme was the problem!

andreas98 gravatar imageandreas98 ( 2018-04-15 15:39:15 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-04-14 17:16:10 +0100

Seen: 61 times

Last updated: Apr 15 '18