Ask Your Question
1

LibreOffice-created Word document won't open normally in Windows Vista [closed]

asked 2012-03-27 14:44:17 +0200

kd5 gravatar image

updated 2013-02-01 10:40:54 +0200

qubit gravatar image

LibreOffice works great with Windows XP. If I create a document using LibreOffice, 'Save As' Word 2007/2010 .docx, then go to My Documents and double-click on the saved document, LibreOffice Writer will open the document perfectly.

Not so with Windows Vista SP2 + all updates.

When I create that same document in Windows Vista, then go the Documents folder and double-click on the file, all it does is bring up a 'Save As' dialog box and prompts me to save the document as a Word 2007 Macro-Enabled Document (by default, but I can choose anything from the list). If I do that, then double-click on the newly created 'Macro-Enabled Document' (or whatever), it brings up the 'Save As' dialog box again, and wants me to save it again, and again, and again. It won't open the document unless I right-click on it and choose to 'Open With', then navigate to LibreOffice Writer, each and every time, regardless of whether I chose to 'Always use the selected program'.

Why?

I'd like to be able to double-click on the newly created Word document and have it open normally just as it does with Windows XP. What do I need to do to correct this behavior?

As an aside, I have also installed the Microsoft 'Compatibility Pack for the 2007 Office System' update, but that does not affect LibreOffice in the least with Windows XP, it shouldn't with Vista either. -kd5-

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-11-01 13:07:02.752473

Comments

Hi @kd5, Have you found an answer to your question? It sounds like there might be some kind of compatibility issue with the Vista OS, but you could try downloading a 3.6 or 4.0 beta build here and see if one of these newer builds solves your problem. Best of luck!

qubit gravatar imagequbit ( 2013-01-25 10:05:23 +0200 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2013-02-19 03:51:09 +0200

qubit gravatar image

Hi @kd5,

There's enough chatter on this Question that it sounds like something should be investigated. If you haven't figured out your problem yet, please file a bug about this problem. The QA team will be happy to help you track down this issue!

Please post a link to any bugs you file in a comment below using the format "fdo#123456".

Thanks!

edit flag offensive delete link more
0

answered 2012-05-17 17:17:26 +0200

Andy Page gravatar image

updated 2012-05-17 17:20:35 +0200

I am having broadly similar problems, i used to be able to save in doc format from LibreOffice or OpenOffice and read using Word 2003 (or maybe 2007), but the same documents will not read from Word2010, it is though Micosoft are checking documents from external tools and rejecting them as containg errors. I consider this a real drawback to using LibreOffice going forward, it isnt necessarily a LibreOffice bug, but it is something that needs to be sorted one way or another !!!!

edit flag offensive delete link more
0

answered 2012-05-22 15:17:34 +0200

I am having similar issues. I am creating docs in LIbreOffice 3.5.3.2 on Ubuntu 12.04 and sending them to Windows users with office 2010 and they report the doc file as being corrupted. It could be a bug in a recent version of LibreOffice but also a feature/bug in Office

edit flag offensive delete link more
0

answered 2015-09-27 18:02:08 +0200

Infti gravatar image

Windows 7x64

LibreOffice 5.0 Version: 5.0.0.5 (x64) Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b Locale: en-US (en_US)

Same problem.

Please don't tell me to upgrade to a newer version, because newer versions have far more serious problems.

Thanks,

edit flag offensive delete link more

Question Tools

Stats

Asked: 2012-03-27 14:44:17 +0200

Seen: 31,458 times

Last updated: May 17 '13