Ask Your Question
0

page numbers in navigator shifted by 2 relative to the actual numbers [closed]

asked 2018-04-19 22:34:25 +0100

Coiske60 gravatar image

Hi,

I copied a book with OCR and I want my Writer-document to have the same page numbers than the original text, with the even pages on the left, the odd ones on the right. To do so I created a blank page before the first page, giving it the number 0 (zero) and I did a page-break in Writer at each page-end in the paper-book .
This works fine, but the page numbers in the Navigator are two units short to the real ones. When I ask to go to the indicated number, Writer jumps to 2 pages before the number I entered in the Navigator.

And the page-indicator at the left of the status-bar shows the 2 numbers (e g "Page 54 of 303 (page 56)" when the cursor is actually on page 56.

Is there a way that the Navigator shows the same number than the actual page-number? Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason duplicate question by Coiske60
close date 2018-05-03 19:42:30.595919

2 Answers

Sort by » oldest newest most voted
0

answered 2018-04-20 08:03:27 +0100

ajlittoz gravatar image

The navigator shows 3 information related to pages because page numbering is purely arbitrary (i.e. under user control):

  • physical state: physical page number of cursor and total page count as Page x of count
  • logical state: page number as defined by user (page z); this latter indication is displayed in the actual page number style (numeric, alphabetic, roman ...) and is removed if page has no number

Note that the "logical" page number is not unique if you choose to number your pages per chapter.

Depending on LO version, this may be shown as Page 56 54/303.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more
0

answered 2018-04-20 08:38:08 +0100

Coiske60 gravatar image

updated 2018-04-22 11:18:04 +0100

thanks for the explanation, but in my text the page numbers start with “1” at the first page ((number “0” for the blank page before the first one is indeed my “logical” choice). Why does the numbering shifts then with 2 units instead of one?C:\fakepath\pagebreaks.odt

edit flag offensive delete link more

Comments

This is not an answer and should have been entered as a comment to mine.

ajlittoz gravatar imageajlittoz ( 2018-04-20 09:12:45 +0100 )edit

If it shifts by 2 units, then you have an extra manual page break. Have you enabled "technical" display as menu View>Nonprinting Characters or Cntrl+F10 to see all formatting hints?

Without information on your document styling, I may also suppose that one of the manual page breaks forces an odd page number thus inserting a blank page.

ajlittoz gravatar imageajlittoz ( 2018-04-20 09:17:54 +0100 )edit

sorry for that, I didn't know the rules yet.

Here is what I tried: In Tools - Options - Writer - Formatting-Aids I left only the Checkbox "Breaks" activated, but I din't see anything of those "manual page breaks "; even if I added a "Ctrl Enter" nothing showed.

In My previous "answer" I added a few pages of my Writer document (I named it "Pagebreaks.odt"), and the problem occurs already on page 1. I hope this should help with my problem.

Thanks and sorry again

Coiske60 gravatar imageCoiske60 ( 2018-04-21 21:44:15 +0100 )edit

You're welcome. Ergonomics of this site is not crystal-clear.

Your document would certainly help, but you didn't upload it. Please try again.

ajlittoz gravatar imageajlittoz ( 2018-04-22 07:51:43 +0100 )edit

I hope i'ts ok now , I think I didn't Save my edit-attachment

Coiske60 gravatar imageCoiske60 ( 2018-04-22 11:19:08 +0100 )edit

On my computer, your document opens as "expected" (with the exception of page containing "blank page (pagenumber 8)" which is #10 but I think this a typo.

I don't see any anomaly. However, you're using, abusing, direct formatting over your custom and other buit-in styles. This will cause you problems. Either opt for full direct formatting (strongly discouraged for structured documents) or adopt an organised set of styles as you have begun and don't patch them with direct formatting.

ajlittoz gravatar imageajlittoz ( 2018-04-22 12:17:43 +0100 )edit

Remember that you have character styles to "locally* diverge from the paragraph style in an organised way.

Also if your document is made of different parts (cover, dedication, content, TOC, …) starting on a new page, don't hesitate to dedicate them different page styles so that you can have different (independent) headers/footers and numbering option and sequence (or no numbering at all).

ajlittoz gravatar imageajlittoz ( 2018-04-22 12:21:38 +0100 )edit

Finally I got the solution: in the "zoom"-dialog I chose "Columns" and "Book", and the odd pagenumpers appear on the right as I wanted, without insertingr a page "0".

Coiske60 gravatar imageCoiske60 ( 2018-05-03 19:36:55 +0100 )edit

I think you inadvertently chose the wrong reason when closing your question.

ajlittoz gravatar imageajlittoz ( 2018-05-03 20:04:06 +0100 )edit

Question Tools

2 followers

Stats

Asked: 2018-04-19 22:34:25 +0100

Seen: 65 times

Last updated: Apr 22 '18