Ask Your Question
0

How to use another language in a fillable form?

asked 2018-05-27 00:12:53 +0200

updated 2018-05-27 00:13:20 +0200

I'm using LO Writer 6.0.4.2. I was using 5.? before this and updated the version just to see if it would solve this problem. It made no difference.

I'm trying to make a document and export it to PDF, with fillable forms. I want to have both English (US) and Russian in the PDF. In the regular text portion of the form, this is not an issue.

However, in the fields, it's not working. I've tried both text fields and formatted fields. In both, the reaction of the PDF is the same...

If I enter English characters into the fields, everything seems fine. When I click on the next field, the characters are still there in that field.

But if I enter Russian characters into the fields, they appear as I'm typing, but once I click on the next field, they disappear. If I click back on that field I just typed Russian letters into, the letters reappear. But once again, if I click on another field, they disappear.

edit retag flag offensive close merge delete

Comments

Please be more specific. Are you trying to fill the fields using any LibreOffice app (and if so which one exactly) or your PDF reader?

Xoristzatziki gravatar imageXoristzatziki ( 2018-05-27 17:04:43 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-05-31 10:44:37 +0200

Xoristzatziki, Your question prompted me to do a little more experimenting.

I was not having the same problem when entering data into fields in the ODT file, only in the PDF files. I'm running Linux Mint 18.2 and it's default document viewer, Xreader, is the PDF viewer I always use. For kicks I installed qpdfview and tried opening the same document. Problem solved.

Whatever the issue is has more to do with the pdf viewer than Libre Office. Thank you Xoristzatziki,

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-05-27 00:12:53 +0200

Seen: 40 times

Last updated: May 31 '18