Ask Your Question
0

local help installation issue

asked 2018-06-08 10:27:15 +0200

rapple gravatar image

Trying to install 6.0.4.2 on Linux Mint 18.3 with GB help file. (I prefer local help for when I'm not online - yes there are a few of us that live disconnected at times).

Don't want to use Flatpak so please, no suggestions in this direction.

I've poked and prodded a bit but I've reached the point where I don't know if I missed doing something or whether the installation dependencies are actually wrong. Any pointers gratefully received to get the help file installed properly.

Here's what I did:

  • Uninstalled the distro version of LO and purged config files.
  • Downloaded 6.0.4.2 64 bit
  • Installed using dpkg

The applications work fine, but the local help shows as not installed within the applications.

However when I go to install the 6.0-en-gb help file I get

rick@tardismint ~/Downloads/LibreOffice_6.0.4.2_Linux_x86-64_deb_helppack_en-GB/DEBS $ sudo dpkg -i *.deb

(Reading database ... 550476 files and directories currently installed.)

Preparing to unpack libobasis6.0-en-gb-help_6.0.4.2-2_amd64.deb ...

Unpacking libobasis6.0-en-gb-help (6.0.4.2-2) over (6.0.4.2-2) ...

dpkg: dependency problems prevent configuration of libobasis6.0-en-gb-help:

libobasis6.0-en-gb-help depends on libobasis6.0-en-gb (>= 6.0.4.2); however:

Package libobasis6.0-en-gb is not installed.

libobasis6.0-en-gb-help depends on libobasis6.0-en-gb (<= 6.0.4.2-2); however:

Package libobasis6.0-en-gb is not installed.

dpkg: error processing package libobasis6.0-en-gb-help (--install):

dependency problems - leaving unconfigured

Errors were encountered while processing:

libobasis6.0-en-gb-help

If I try to fix using apt-get

The following packages will be REMOVED

libobasis6.0-en-gb-help

0 to upgrade, 0 to newly install, 1 to remove and 26 not to upgrade.

1 not fully installed or removed.

After this operation, 25.7 MB disk space will be freed.

Do you want to continue? [Y/n]

...and while trying to remove some other stuff using autoremove showed:

DEBS $ sudo apt-get autoremove

Reading package lists... Done

Building dependency tree

Reading state information... Done

You might want to run ‘apt-get -f install’ to correct these.

The following packages have unmet dependencies.

libobasis6.0-en-gb-help : Depends: libobasis6.0-en-gb (>= 6.0.4.2) but it is not installable

Depends: libobasis6.0-en-gb (<= 6.0.4.2-2) but it is not installable

E: Unmet dependencies. Try using -f.

Which squares with the content of the control file in the help .deb

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-06-09 08:39:42 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

You can't install versions non supported by your OS without problems and most of the times you cannot install them at all because of missing dependencies. For how to install missing dependencies (if it is overall possible, without screwing the whole system) the right place depends on your repo.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-06-08 10:27:15 +0200

Seen: 290 times

Last updated: Jun 09 '18