Ask Your Question
0

Asian(Korean) Word Editing Issue at Writer [closed]

asked 2013-04-07 06:24:21 +0200

kdoodoo gravatar image

updated 2015-10-29 15:58:07 +0200

Alex Kemp gravatar image

Since I am using English and Korean at the same time, I found it is the issue only found when I am typing Korean.

Take a line of words you are typing. So you typed through the end of the line and you found there is a typo at the beginning of the line. So you click the cursor at the beginning where you want to insert a new word. But the word you newly typed in is not there but going into the end of the line where you left with.

For Example,

많은 시간과 토론을 투자 : you typed one line and want to add a word(는) at the beginning of the line

는많은 시간과 토론을 투자 : you expect

많은 시간과 토론을 투자는 : Result is

I think the reason is when I am typing Korean, the Libreoffice automatically selects the last Korean word typed.

PS: I am using mac so not sure about other OS does the same.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-10-29 15:58:25.057325

Comments

thanks oweng but that's not working....

kdoodoo gravatar imagekdoodoo ( 2013-04-10 16:40:09 +0200 )edit

Is FDO#48343 related? Here, under Format > Paragraph… > Asian Typography tab, I have all three Line change options checked.

oweng gravatar imageoweng ( 2013-04-11 11:35:19 +0200 )edit

@oweng - I had a look at the bug you mentioned but I am really sure if the problem is related. In respect to the bug I made a test with Japanese but could not see the bug.

ROSt52 gravatar imageROSt52 ( 2013-04-11 12:16:16 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2013-04-07 08:22:50 +0200

oweng gravatar image

Tools > Options... > Language settings > Complex text layout > Cursor control try changing the selection from "Logical" to "Visual". That option may help if you are making use of bi-directional text features.

edit flag offensive delete link more
0

answered 2013-04-11 02:52:07 +0200

ROSt52 gravatar image

updated 2013-04-11 03:06:44 +0200

IMHO @kdoodoo observed a bug I am also seeing in English. Sometimes the same happens typically, but not necessarily always, after a copy&paste action. In this case the non-printing character for carriage return appears at the left side outside the left side border line. Selection of the strange behaving text and ctrl+m solved so far the problem. However, I could not really reproduce the error and thus could not report.

Reading @kdoodoo's explanations it seems that he can reproduce the error.

@kdoodoo - could you please file a bug report? If possible please make a link to this question here so the QA guys see that there is also a bug in English. Posting the link to the bug here would enable others to add comments to your bug report.

LibO Version 3.6.5.2 (Build ID: 5b93205) XP Prof / SP3; Asian language support package installed

edit flag offensive delete link more

Comments

@ROSt52 I will defer to you for this one. My answer was the only thing I could think of. I use bi-directional text settings on occasion but do not make use of the related text input. I have read elsewhere about the copy / paste issue you mention (but usually in bi-di contexts). Like you, not sure if that is related or not. I am out of ideas.

oweng gravatar imageoweng ( 2013-04-11 03:15:03 +0200 )edit

@oweng - please stay tuned. You are really an LibO expert! I just saw that @kdoodoo observed the same(?) bug as I did in English. I haven't seen the bug yet in Japanese, my second most often used language. What does bi-directional context actually mean? I search the help wiki but did not find the answer.

I just hope I can reproduce the bug in English soon.

ROSt52 gravatar imageROSt52 ( 2013-04-11 04:13:14 +0200 )edit

@ROSt52, I will look into this further. My initial answer was wrong as Korean is left-to-right (LTR) when set horizontally, and the Complex Text Layour (CTL) options really only apply to right-to-left (RTL) scripts e.g., Arabic, Hebrew, etc. I thought the text may have directional formatting codes: http://www.unicode.org/reports/tr9/#Directional_Formatting_Codes I now agree it more likely to relate to the text input method (or en/ko mixture thereof) and be a bug in LO.

oweng gravatar imageoweng ( 2013-04-11 05:29:48 +0200 )edit

@owen - Thanks for the link - this bi-di stuff looks pretty complex. Korean belongs to the Asian group of languages including beside Korean, Japanese and 6 versions of Chinese. I don't know if you can see it but in tools / options / languages /... I can see Western, Asian, and CTL. I might see Asian languages only due to the installation of Japanese.

I am now curious about @kdoodoo's reply.

ROSt52 gravatar imageROSt52 ( 2013-04-11 11:18:02 +0200 )edit

Question Tools

Stats

Asked: 2013-04-07 06:24:21 +0200

Seen: 400 times

Last updated: Apr 11 '13