Ask Your Question
1

Calc - how to enter text without the single or double quote showing?

asked 2018-06-17 03:21:43 +0100

Raptor88 gravatar image

Calc - Assume I want to enter text in a cell that has been pre assigned as a date cell (the whole column is for dates).

In MS Excel, I used to enter text into a cell by typing a single quote first, followed by the text. The leading single quote would not show in the text.

When I do the same thing in Calc, the single (or double) quote shows along with the text. How do I enter text in a date cell without the leading quote showing?

(I could assign the formatting of the single cell to "text" but that is too cumbersome compared to just entering a leading quote to tell calc that the cell should be text.)

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2018-06-17 10:27:16 +0100

pierre-yves samyn gravatar image

Hi

In all the versions I used the quote entry works as expected: recognition of the input as text.

As the screenshot below shows, the quote is only displayed in the formula bar. In the cell itself (and of course in preview or print) the quote is not displayed.

image description

One hypothesis that could explain your dysfunction would be, for example, an auto-correction that would replace the quote in another typographic sign (see for example Tools AutoCorrect options Localized

HTH - Regards

edit flag offensive delete link more

Comments

Hi pierre-yves, Thank you for confirming that Calc should work like Excel in not showing the leading quote in the cell itself. I checked Tools > AutoCorrect options > Localized Options but could not find a culprit. Something is wrong with my 5.3.4.2 (x64) version of Calc. I'm just using Calc for personal use so I can live with the leading quote showing in the cell until someone experiences the same and posts the fix.

Raptor88 gravatar imageRaptor88 ( 2018-06-18 10:53:02 +0100 )edit
0

answered 2018-06-18 15:07:43 +0100

erAck gravatar image

You only need to prefix input with ' apostrophe if it could be interpreted as numeric (number, date, time, ...) and then the apostrophe shows just in the Input Bar, not as cell content. Otherwise, for text that could not be interpreted as numeric just enter the text. If you prefix text that could not be interpreted as some numeric input then the leading apostrophe is assumed to be part of the text entered. If the cell was already formatted as Text prior to input then all input entered will be text content, including a leading apostrophe, no matter whether the input could be interpreted as numeric or not.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2018-06-17 03:21:43 +0100

Seen: 322 times

Last updated: Jun 18 '18