Ask Your Question
0

base error: no SDBC Driver found

asked 2018-07-03 20:39:15 +0200

Rbiker gravatar image

When trying to use a LO database, I get the following error message: No SDBC driver was found for URL: Sdbc:Embedded:hsqldlb. Any ideas on how to correct it?

edit retag flag offensive close merge delete

Comments

@Rbiker Please give following minimum information - OS used, Lo version & whether 32 or 64 bit, type of database used to connect to. Also, have you installed Java? What version, JRE or JDK and is it 32 or 64 bit?

Ratslinger gravatar imageRatslinger ( 2018-07-03 20:52:46 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2019-06-27 23:44:11 +0200

fgotsis gravatar image

updated 2019-06-27 23:44:51 +0200

Hello,

I had the same problem using OpenSuse 15.0. In my case the problem was that as the error stated the driver was missing and it was not installed automatically.

With OpenSuse you need to install the package "libreoffice-base-drivers-firebird"

Package description libreoffice-base-drivers-firebird - Firebird Database Driver for LibreOffice This package allows to access Firebird databeses from LibreOffice Base.

You can do that with yast (the setup tool of OpenSuse).

I am afraid that this will only help to get past this error with firebird and its integration in LibreOffice. The messages are not very helpful and the GUI supported options dialog is not doing any self check for the required dependencies to make firebird run.

kind regards Franz

edit flag offensive delete link more

Comments

@fgotsis,

It would appear in your experience that the LO version you are using is a distro version. All PPA and TDF versions I have used include the mentioned "package". Distro versions are notorious for not including Base and even after installing that portion other pieces are missing in Base such as parts for Report Builder.

Ratslinger gravatar imageRatslinger ( 2019-06-28 01:25:40 +0200 )edit
1

answered 2018-07-05 20:08:35 +0200

Ratslinger gravatar image

Hello,

Can't give a definitive answer based upon information given thus far. My guess is a possible incorrect Java installed. Java and LO must match bit-wise. 32-bit LO needs 32-bit Java. 64-bit LO needs 64-bit Java. From the menu, go to Tools-Options and under LibreOffice->Advanced you will see:

image description

Insure Use a Java runtime environment is checked and you should (within a few seconds) have your Java appear in the pane if the 64-bit version is installed. If it appears, make sure it is selected (can have many Java versions installed). If nothing appears, please install the 64-bit version from Oracle (OpenJDK should also work).

If this is not the problem, then possibly the data base you have connected to in the past originated form Access. If this is the case, it is a problem with connectors. See this post -> I got error "The connection to the data source "DB file name" could not be established." for links to a couple of possible solutions.

As you can see, information in important in determining what the problem may be. The more information you can provide on what is going on (like upgrading from another LO version; 32 to 64 bit; DB change) the more likely someone can help. Without the info, it is best guess.

edit flag offensive delete link more

Comments

Hi - I downloaded and installed the Java program but Libre Office could not automatically locate any JRE. I searched my HD with Windows Explore, located Java folders with different vs numbers, but Libre Office could not find and JRE in any of the folders I located. I finally ran Oracle's online Java uninstall program and completely deleted JAVA. I downloaded and installed the latest JAVA, restarted my PC and all is OK. Thank you for your help. How do I tag this as "Solved"

Rbiker gravatar imageRbiker ( 2018-07-09 16:32:55 +0200 )edit

Glad all is working. Probably incorrect bit version from previous set up. Deleting wasn't necessary as you can have many versions installed. Just need to select one in Base. I have 4 or so installed.

As you have been helped, please help others to know the question has been answered by clicking on the ✔ in upper left area of answer which satisfied the question.

You can also close the question by clicking on the X close lower right corner of your question.

Ratslinger gravatar imageRatslinger ( 2018-07-09 16:51:48 +0200 )edit

I'm having a similar problem except all of a sudden, LibreOffice can't find ANY Java on my computer no matter what I do even though it formerly worked. I changed nothing in this regard. Fun stuff. Though it seems like it shouldn't be necessary, I'm going to try what @Rbiker did - uninstall Java and start from scratch. LO seems pretty finicky in how/whether it finds Java, even if you point it directly to the correct folder in options - advanced. It comes and goes based on mood swings I guess.

PhLo gravatar imagePhLo ( 2018-11-18 10:07:41 +0200 )edit

@PhLo In the years of using LO (both Windows & multiple Linux systems) have not had any problems with Java. Have used JDK, JRE & OpenJDK from version 6 through 10. All these because of either upgrades in version or because of testing for others. It has not come and gone or been finicky. I can install to system folders where it is found automatically or place it in a user folder where when pointed to it remains. Currently have six versions installed & no problems in this regard.

Ratslinger gravatar imageRatslinger ( 2018-11-18 14:59:14 +0200 )edit

@ebot helped me by showing me it was related to a corrupt user profile. Once I reset that in safe mode, normal functionality was restored, and Java became visible again. However, Base is crazy unstable when I connect to MySQL remotely. If MySQL is installed locally, no problem. Remotely... and it's hard NOT to crash Base with every mouse click. It's kind of disheartening. The stuff I'm experiencing might not relate to Java. Java not showing up was simply one of the many sour symptoms.

PhLo gravatar imagePhLo ( 2018-11-18 15:40:19 +0200 )edit
0

answered 2018-07-05 19:44:43 +0200

Rbiker gravatar image

Hi - I am running Windows 10, Java JRE 8 update 171 vs 64bit, LO vs 6.05 (Just installed it. Had same problem with earlier versions - 5.4xx - before I tried vs 6-05). The type of data base??? I am not a power user and just created the data base(s) with the databases residing on my PC. None of them work. They have worked fine for several years with earlier versions of LO . I have also changed from Firefox to Windows Explorer as my default browser - problem persisted

Note I deleted earlier vs of LO and just installed the latest 6.05 Fresh version - problem continued.

edit flag offensive delete link more

Comments

@Rbiker Please use comment or edit question when adding information. Answers are to respond to original question.

Ratslinger gravatar imageRatslinger ( 2018-07-05 19:49:36 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-07-03 20:39:15 +0200

Seen: 2,038 times

Last updated: Jun 27