Ask Your Question
0

Special Separater Character as Delimiter in imported .csv file [closed]

asked 2013-04-14 20:15:36 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hello, In LibreOffice calc how do I specify an other separator that cannot be typed for importing my .csv file? My separator is x'B5' (micro symbol). I have tried x'B5' and 181. Neither of those work. Rob Burness

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-30 08:23:25.104869

Comments

@qubit Thanks for the suggestion. Copying U+00B5 did not work however.

Blue_bullet gravatar imageBlue_bullet ( 2013-04-14 21:20:43 +0200 )edit

@Blue_bullet -- did you try to copy this symbol directly --> "µ" ?

qubit gravatar imagequbit ( 2013-04-14 21:26:32 +0200 )edit

No, but I just tried it by copying µ from your comment above. That does not work either. The x'B5' shows as a rectangle in the preview pane for import and again as a rectangle in calc. I have verified the character is x'B5' in an editor (The Hessling Editor-the). In fact I used the to create the .csv file.

Blue_bullet gravatar imageBlue_bullet ( 2013-04-14 21:33:10 +0200 )edit

@qubit I tried your .csv file with no conversion. I have a snapshot of your file renamed from snapshot1.png to snapshot1.ods but do not know how to post the link as you did for mu-csv.csv.ods. I am running Linux Mint 14 KDE (64 bit) LO 4.0.2.2. file:///home/rob/Documents/snapshot1.ods Character set is Greek (DOS/IOS2-737) on Text Import Screen.

Blue_bullet gravatar imageBlue_bullet ( 2013-04-14 22:29:11 +0200 )edit

@Blue_bullet -- I gave you a bit more karma so you can comment on my Answer and upload files.

qubit gravatar imagequbit ( 2013-04-14 22:34:29 +0200 )edit

@Blue_bullet -- can you upload an example of your CSV file? (rename to XYZ.ODS so you can upload the file)

To upload a file, use the paperclip icon in the GUI.

Thanks!

qubit gravatar imagequbit ( 2013-04-14 22:35:49 +0200 )edit

I have a sample file to upload but do not see a paper clip anywhere in the gui. I see a link but no paper clip. edit: I found the paper clip by using Answer instead of Comment.

Blue_bullet gravatar imageBlue_bullet ( 2013-04-14 23:04:18 +0200 )edit

2 Answers

Sort by » oldest newest most voted
1

answered 2013-04-14 20:42:50 +0200

qubit gravatar image

updated 2013-04-14 22:14:42 +0200

Hi @Blue_bullet,

Have you tried copying and pasting-in the unicode symbol? Wikipedia says that U+00B5 is this symbol: µ


Update: Here's a CSV file separated by the U+00B5 symbol (Note: Please change ODS extension to CSV -- the Ask site has a restrictive set of allowed file extensions):

I can import this CSV file into LO 4.0.2.1 on Ubuntu 12.04.2 without any problems.

edit flag offensive delete link more

Comments

As I look at your .csv file in the I see two characters, a x'C2' followed by a x'B5'. x'C2' is latin capital letter A with circumflex. My file is delimited only by x'B5'.

Blue_bullet gravatar imageBlue_bullet ( 2013-04-14 23:17:03 +0200 )edit
1

I don't know if this helps but @Blue_bullet's csv is encoded as ANSI and @qubit's as UTF-8. You can use a text editor to change encoding (I use Notepad2-mod http://xhmikosr.github.io/notepad2-mod/)

Pedro gravatar imagePedro ( 2013-04-14 23:58:11 +0200 )edit
1

This basically sorted as a file encoding issue thanks to @qubit and @Pedro. Here is my test: $ file -bi file.csv

oweng gravatar imageoweng ( 2013-04-15 11:37:04 +0200 )edit

@oweng is correct @cubit provided the solution: Hi @Blue_bullet, If I set my Character set to "Western Europe (ISO-8859-1), and if I then put the character "µ" into the Other field, I can import your document, split into (I believe) the correct columns. qubit (15 hours ago)

Blue_bullet gravatar imageBlue_bullet ( 2013-04-15 17:58:33 +0200 )edit
0

answered 2013-04-14 23:12:27 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Sample .csv file for delimited file using x'B5'. Rename .ods to .csv.

C:\fakepath\delimit_test.csv.ods

edit flag offensive delete link more

Comments

1

Hi @Blue_bullet,

If I set my Character set to "Western Europe (ISO-8859-1), and if I then put the character "µ" into the Other field, I can import your document, split into (I believe) the correct columns.

qubit gravatar imagequbit ( 2013-04-15 02:52:15 +0200 )edit
1

@cubit You solved my problem. Using the Western Europe (ISO-8859-1) character set loads the file properly. Thank you for your help. I had never paid attention to the Character Set selection box on the Text Import Screen before.

Blue_bullet gravatar imageBlue_bullet ( 2013-04-15 17:46:45 +0200 )edit

Question Tools

Stats

Asked: 2013-04-14 20:15:36 +0200

Seen: 1,892 times

Last updated: Apr 14 '13