LibreOffice doesn't recognize extension .ods [closed]

asked 2013-04-16 20:36:22 +0200

emdasher gravatar image

updated 2015-09-10 10:57:51 +0200

Alex Kemp gravatar image

Using XP, LibreOffice does not recognize extension ods. When I try to open a calc document from the My Documents list, I am referred to a Windows help page for extension identification. The program also fails to place a shortcut to the document in the Recent Documents list. To access the calc file, I have to open the LibreOffice program, go to File, and open the document from there. I am using the latest program version, I believe, inasmuch as I downloaded it from Kim Komando yesterday (04/15/13). This calc document was created with Open Office. Everything worked flawlessly with that program.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-10-04 18:42:50.116850

Comments

I am using LibO 3.6.5.2 on XP Prof/SP3 and a double click opens ods and other LibO files.

Which version of LibO are you using?

Did you reset your user profile?

ROSt52 gravatar imageROSt52 ( 2013-04-17 04:42:40 +0200 )edit
2

This looks like Windows XP problem not having associated .ods file with LibreOffice. This problem should be solved during installation of LibreOffice. However now try this: 1. Open Windows Explorer.
2. Menu Tools | Folder Options.
3. File Types tab.
4. Click New button.
5. In File Extension type in ods and select Associated File Type to "Spreadsheet OpenDocument" (or something similar, I got this data displayed in my native non-English language).

Hope this helps.

froz gravatar imagefroz ( 2013-04-17 07:36:11 +0200 )edit
1

In my humble opinion, if double clicking a file in Windows does not open a LibreOffice then this has nothing to do with LibreOffice, but a problem at Windows that can't associate file type to appropriate program (in this case LibreOffice). So any change (like resetting profile) in LibreOffice will not have any effect at running a program from Windows.

froz gravatar imagefroz ( 2013-04-17 07:38:35 +0200 )edit
1

Not an answer, just my feedback.

I'm working on windows 7. I've worked with openoffice till yesterday, so I'm plenty of ods files. Then I installed LO, and I can open .ods files.

So +1 to froz's answer (I don't have sufficient reputation points yet to vote froz's answer!)

Hope this helps

Marco Panichi gravatar imageMarco Panichi ( 2013-04-24 11:03:54 +0200 )edit

now you have some karma!

ROSt52 gravatar imageROSt52 ( 2013-04-24 14:06:09 +0200 )edit
2
manj_k gravatar imagemanj_k ( 2013-04-24 20:52:08 +0200 )edit
1

The reason LO is not recognizing the file is because the file type is not associated with the application in i.e.in this case .ods file to be opened with LO.

To do this manually: 1 ) right click on the file > scroll down to Open With option click the option , a new dialogue box opens up search and point (select) the Program in this case LO ,

make sure the check box:"Always use selected program to open this kind of file is checked and click ok at the bottom.

Thats it! Now your .ods files have been associated with LO and just double clicking will cause Xp to open the .ods file with LO by default.

n.b. if in any case you can't locate LO , you should click browse and locate the LO "exe" file from there (in your installation directory)

 -alternatively to locate the LO ...
(more)
john.bandaru gravatar imagejohn.bandaru ( 2014-06-09 12:19:01 +0200 )edit