Ask Your Question
0

Base form 'input required' does not work [closed]

asked 2018-08-23 21:18:32 +0100

impocta gravatar image

updated 2018-08-23 23:19:45 +0100

I added several new collumns to an existing table with data in it. At creation I marked these collumns: 'input required: no' because I don't know the correct content of these new collumns for the existing data, so these new collumns should remain empty for the already existing data.

However, for newly added data I want these new collumns to be mandatory for record creation. I imagined a solution to this exeption as follows: I have a form for new record creation only. Through the control dialog of the new collumns and then the data tab, I marked 'entry required' as 'yes'. I imagined that this configuration would prompt an error if the user tried to save a new record while the form controls of the new collumns were still empty. Sadly enough, it does not work. With the above described strategy I can create new records without filling out the new collumn form controls. I tried it with 'Empty string is NULL' both 'yes' and 'no'.

I am using LO Base 6.0.3.2 Build ID: 1:6.0.3-0ubuntu1 connected to an online MySQL database through driver: mysql-connector-java-5.1.45 on Xubuntu 18.04

My question is: how can I tackle this 'input required' exception through a form?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by impocta
close date 2018-08-26 13:21:49.636013

2 Answers

Sort by » oldest newest most voted
1

answered 2018-08-23 22:49:52 +0100

Ratslinger gravatar image

Hello,

This is not working because of -> Bug #75341. Have also confirmed this in a test.

Only way I could see around this is to have a macro run before updating record which would verify input for required fields and approve or cancel update depending on entry. This needs to be written specifically for your form.

edit flag offensive delete link more

Comments

Thank you very much for this clear answer! It feels so great to know that it is a bug in the software and not just my own impotence.

I expect that this bug won't be solved anytime soon, considering that it is known for quite some time now. I have no experience in macro coding yet and mentally I'm not ready to learn yet another language after diving into SQL. So, I think I'll let this issue rest for now and pray/hope that the fix of the bug will arrive soon.

impocta gravatar imageimpocta ( 2018-08-23 23:19:26 +0100 )edit

@impocta Bug has been fixed and have tested in LO v 6.1.2.1

Ratslinger gravatar imageRatslinger ( 2018-10-13 02:19:55 +0100 )edit

Great news!

impocta gravatar imageimpocta ( 2018-12-08 20:36:10 +0100 )edit
0

answered 2018-08-24 00:08:30 +0100

peterwt gravatar image

If you are not confident about creating a macro there is an alternative. You could run a SQL update query on the Table to put something in the empty fields such as "Not Known". If you only have a small number of records you could do it manually. You can then set these fields in the table to have input required to yes.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2018-08-23 21:18:32 +0100

Seen: 161 times

Last updated: Aug 24 '18