Ask Your Question
0

LO fails to load on netboot conversion. Signal 11

asked 2018-09-20 23:36:14 +0200

ktong gravatar image

Hi everyone, I administer a group of Ubuntu 16.04 based netboot machines that pulls from a netboot image from a server. I would like to update LO from 5.0 in the image to 6.0. I did that by turning on a VM with the base image, added LO PPA repository, then apt-get install libreoffice. It works fine when LO runs in the VM. However, when I convert it to the netboot, the resulting netboot environment won't run LO. The error message are as follows when I run from the terminal:

================================================================

Fatal exception: Signal 11

Stack: /usr/lib/libreoffice/program/libuno_sal.so.3(+0x3b200)[0x7f43c3386200] /usr/lib/libreoffice/program/libuno_sal.so.3(+0x3b370)[0x7f43c3386370] /lib/x86_64-linux-gnu/libc.so.6(+0x354b0)[0x7f43c2fb04b0] /usr/lib/libreoffice/program/libuno_cppu.so.3(uno_type_any_assign+0x6e9)[0x7f43bc98ffe9] /usr/lib/libreoffice/program/libmergedlo.so(+0x29c3f2e)[0x7f43c5f66f2e] /usr/lib/libreoffice/program/libmergedlo.so(+0x29c4d9e)[0x7f43c5f67d9e] /usr/lib/libreoffice/program/libmergedlo.so(_ZN3utl10ConfigItemC2ERKN3rtl8OUStringE14ConfigItemMode+0x84)[0x7f43c5f5b634] /usr/lib/libreoffice/program/libmergedlo.so(+0x2a23828)[0x7f43c5fc6828] /usr/lib/libreoffice/program/libmergedlo.so(_ZN19SvtSysLocaleOptionsC1Ev+0x15c)[0x7f43c5fc7a3c] /usr/lib/libreoffice/program/libmergedlo.so(_Z7InitVCLv+0x1c4)[0x7f43c63221d4] /usr/lib/libreoffice/program/libmergedlo.so(+0x2d8093d)[0x7f43c632393d] /usr/lib/libreoffice/program/libmergedlo.so(_Z6SVMainv+0x22)[0x7f43c6323992] /usr/lib/libreoffice/program/libmergedlo.so(soffice_main+0x8a)[0x7f43c53279ca] /usr/lib/libreoffice/program/soffice.bin[0x4006eb] /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0)[0x7f43c2f9b830] /usr/lib/libreoffice/program/soffice.bin[0x400729]

=========================================================== I tried renaming the personal profile folder located at /home/user/.config/libreoffice I also tried running it in safe mode.

Anyone with any idea why it works in VM but not in netboot? The only difference (I believe) is that in netboot the program folder becomes read-only.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2019-04-27 20:52:59 +0200

Boba Fit gravatar image

Hi I had the same problem after upgrade from Ubuntu 18.10 to 19.04. I moved the folder ~/.config/libreoffice to ~/.config/libreoffice.bak then i lost my confiigration, but libreoffice started.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-09-20 23:36:14 +0200

Seen: 219 times

Last updated: Apr 27