Ask Your Question
0

Altering the Colour of Highlighting of Text found by Search in Writer

asked 2018-09-24 13:03:55 +0200

StephenM gravatar image

Good Evening

I have thought about whether or not to ask this question after having searched for days looking for, and not finding, a definitive answer online.

I'll start with my configuration. I am running Linux Mint 19 (Cinnamon 3.8.9). It's pretty much a stock standard version with little or no tweaking of the UI. My version of LibreOffice is 6.1.1.2.

When I search for text in LibreOffice Writer I have trouble seeing it on the screen in daylight. Indeed, I have trouble even finding the highlighted text. The highlight colour is a pale blue shade (Hex #e6edde). I would really like to configure that colour to be something much more easy to see.

My problem is that I cannot even determine if that colour is set by LibreOffice or if it is a Linux Mint one. I can easily change the highlighted text colour in, say, XEmacs. That's an XEmacs configurable option.

After extensive reading online, and finding information that pertains only to older versions of LibreOffice and Linux Mint, I am none the wiser.

I have found no way to change it in LibreOffice. I have searched every single file in my home directory structure and am unable to find #e6edde in any file. I also tried using the "strings" command to search all files under my Libreoffice installation directory on the off chance that it was in one of the binaries in plain text. No luck with either.

Can anyone give me definitive answers to the following as applies to my versions of Linux MINT and LibreOffice?

  1. Is the text highlighting colour determined by LibreOffice or Linux MINT?
  2. If it is set by LibreOffice, can it be changed?

If it is a Linux MINT setting, then I will take my questions to the appropriate Linux MINT forum.

If I have left out any relevant information please let me know and I will rectify.

Thanks in advance for any advice.

regards Stephen Meatheringham Canberra, Australia

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2018-09-26 23:59:06 +0200

KH gravatar image

I checked the options in LO for Application Colors, but there's no entry for the selection color.

Answers to previous questions are mixed [1] [2].

The suggestion to change the OS settings didn't work for me. I'm on KDE Plasma 5.12.

The option in LO to change the selection transparency did work. It's hidden under Expert Config. Tools > Options > LibreOffice > Advanced, then Open Expert Configuration. Search for "transparent" and change "TransparentSelectionPercent" to a lower number. I had to restart LO before the change took effect.

If no one else can provide a method to change the actual color, I would try this last option. It may take some trial and error to find a transparency level such that you can see the highlighting without the text becoming unreadable.

[1] https://ask.libreoffice.org/en/questi... [2] https://ask.libreoffice.org/en/questi...

edit flag offensive delete link more

Comments

Thanks for taking the time to have such a thorough look at this. If I alter the transparency (dropping it to 30%) then it makes it considerably easier to find on the screen in a brightly lit room. Anything lower makes it impossible to see the text underneath. I guess this will do as a workaround.

StephenM gravatar imageStephenM ( 2018-09-28 11:50:04 +0200 )edit

Good to hear. If you could, please "upvote" and "accept" this answer accordingly.

KH gravatar imageKH ( 2018-10-01 00:16:40 +0200 )edit

This worked great for me -- I was having same problem as StephenM -- thank you KH!! The transparency change to 30% did the trick. Now I can find the text I search for!

asandl gravatar imageasandl ( 2019-06-06 21:59:38 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-09-24 13:03:55 +0200

Seen: 161 times

Last updated: Sep 26 '18