Ask Your Question
1

I am unable to install Personas [closed]

asked 2013-04-28 05:24:56 +0200

pgrytdal gravatar image

updated 2015-08-29 21:00:03 +0200

Alex Kemp gravatar image

I am on Ubuntu 13.04, running Libre Office Version 4.0.2.2 (Build ID: 400m0(Build:2))

image description

I go to Tools > Options > Libre Office > Personalization

I click on the "Select Personas" option then click the "Visit Firefox Personas" website. I find one I like so I copy the URL from the Adress bar like I'm instructed to do. Then I put the URL into the Libre Office field

image description

Click "Okay" and then... the same window pops up again. I think I am doing everything right... Could someone please tell me if I'm doing anything wrong?

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-10-30 21:39:14.852961

Comments

me too, it was working until an update occurred to mozilla persona website.

jiero gravatar imagejiero ( 2013-04-28 09:15:42 +0200 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2013-04-28 10:58:13 +0200

manj_k gravatar image

updated 2013-04-28 10:59:06 +0200

Reported as
Bug 63498 - Personas doesn't work anymore
Status: RESOLVED FIXED.

The patch will be available in LibreOffice 4.0.3.

edit flag offensive delete link more
3

answered 2013-04-29 19:16:32 +0200

carnendil gravatar image

If you cannot wait for the update that fix the but, then you can try to install personas manually (offline).

More detailed instructions given here:

Copy the 'Personas' image files from your Firefox or follow the instructions given here to download the image files.

LibreOffice 'Persona' image files are saved in folder .config/libreoffice/4/user/gallery/personas/.

To reuse 'Personas' in LibreOffice you can (I would recommend option 2 as safest):

Option 1:

  1. Copy the image files in the LibreOffice personas folder
  2. Be very careful about this:

    gedit .config/libreoffice/4/user/registrymodifications.xcu
    

    find (Ctrl+F) the line with PersonaSettings and change the names of the current files to the ones you just copied. Be careful to match "header" and "footer" file names.

  3. Close and re-open LibreOffice.

Option 2

  1. Rename the files of the current 'Persona' in the LibreOffice personas folder (but take note of their current names).
  2. Copy the downloaded image files to that folder and rename them to match the previous names.
  3. This way, you avoid having to edit the .xcu file (which, if not done carefully, might bring a lot of problems).
edit flag offensive delete link more
1

answered 2013-04-28 14:22:13 +0200

petermau gravatar image

You can try loading the Persona by hand. LibreOffice 4 picks up the Personas from the following folder:

on Ubuntu /home/yourname/.config/libreoffice/4/user/gallery/personas

On Win XP /Documents and Settings/yourname/Application Data/Libreoffice/4/user/gallery/personas

And select OWN PERSONA in TOOLS / OPTIONS / Personalisation. If there is already a Persona in the folder OWN PERSONA should select the file. Works on my 4.0.2.2 XP and Ubuntu 12.04 systems.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-04-28 05:24:56 +0200

Seen: 3,657 times

Last updated: Apr 29 '13