Ask Your Question
1

libre office documents will only open as read only [closed]

asked 2018-10-16 08:52:45 +0200

g2gsoon gravatar image

updated 2018-10-16 09:17:32 +0200

ebot gravatar image

I upgraded from a 32 bit to a 64 bit pc. My libre office documents will now only open as read only. There are no ~lock files. Opening in linux on a dual boot m/c

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by g2gsoon
close date 2018-10-21 10:11:59.983694

3 Answers

Sort by » oldest newest most voted
2

answered 2018-10-16 09:26:29 +0200

robleyd gravatar image

It is possible that there is a difference between the file permissions as they were on the old computer and the new computer, perhaps related to the user name? In any case, check that the file permissions allow your current username to both read and write the LO files.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more
1

answered 2018-10-21 10:11:07 +0200

g2gsoon gravatar image

Woks now. Thanks to those who replied.

edit flag offensive delete link more
0

answered 2018-10-16 09:48:52 +0200

ajlittoz gravatar image

This a matter of file owner's permissions. If the file was not created under the same user-id as the one you are using for reading, permissions for group or "others" are in effect depending on the current group-id.

During your upgrade, the user-ids and group-ids may have changed if you created them in a different order. The numeric encoding for the initial ones remained on the disc, resulting in the conflict you experienced.

Your options is either to restore the old id's or to re-own the files.

  • restore old id's

If there is no corresponding user and and group for UID and GID, command ls -l will list numeric UID and GID. Then you can reassign those id's to your user-id (under root mode) with (adapt to your configuration)

   usermod -u 999 mynewuser` and `groupmod -g 999 mynewgroup
  • re-own files

    • if you happen to known your old UID and GID, you can do a system-wide operation with

      find / -group 999 -exec chgrp -h mynewgroup {} \;
      find / -user 999 -exec chown -h mynewuser {} \;
      
    • otherwise, you must process each directory manually with chown and chgrp commands

Use man <command> for details.

In the simplest case, when UID and GID are correct, you may solve the issue by changing permissions on the files with chmod o+rw g+rw o=r <file-name>.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2018-10-16 08:52:45 +0200

Seen: 71 times

Last updated: Oct 21 '18