Ask Your Question
0

Insert unformatted text breaks "language for all text" setting

asked 2018-10-26 07:46:15 +0200

vizim gravatar image

updated 2018-10-26 08:07:45 +0200

Hello. First of all let me say thanks for one of the greatest opensource project. And back to business. My default settings for "language for all text" is "Russian" (my native language). If i open a new document and then insert unformatted text in my native language, all the inserted text becomes underlined and the setting suddenly goes back to "English". All the active language settings in LO except western was set to "Russian". I don't know is it a bug or just a feature. Anyway please let me know how should i fix it or should i deal with it and turn "language for all text" every time. LO version is 6.0.6.2 (x64). Thanks in advance!

edit retag flag offensive close merge delete

Comments

I confirm the problem. It may be a limitation of some kind. However it does not bother me much.

gabix gravatar imagegabix ( 2018-10-26 08:04:20 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-10-26 08:22:26 +0200

Well - about "is it a bug or just a feature" - that is a tricky question.

When you input a text, by default it has a language deduced from your active system input language / keyboard layout (see OptionsLanguage SettingsLanguages[ ] Ignore system input language). When you are pasting a copied text (without format), it seems to also take the active input language into account (at least here on Win 10). So, if I paste with Russian keyboard layout active, it pastes with Russian applied.

edit flag offensive delete link more

Comments

Unfortunately not for me. Tested both turned on and off option "Ignore system input language". Even if i paste when current keyboard layout set to "Russian", i get all the text underlined.

vizim gravatar imagevizim ( 2018-10-26 08:41:52 +0200 )edit

In my case, the problem appears irrespective of the active layout on Windows 7 / Russian and seems to be absent in openSUSE Linux Leap 42.3.

gabix gravatar imagegabix ( 2018-10-26 08:48:21 +0200 )edit

gabix, just tried on fedora 28 - result is the same as on windows. I have no idea what is the problem. Probably it's depending on LO version. On openSUSE 42.3 current LO version is 6.0.5.2. On Fedora 28 it's 6.0.6.2-1.fc28. I'll try with another version.

vizim gravatar imagevizim ( 2018-10-26 13:39:21 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-10-26 07:46:15 +0200

Seen: 18 times

Last updated: Oct 26 '18