Calc locks up on autosave

asked 2018-11-07 04:13:13 +0200

PS25 gravatar image

I have tracked down a peculiar issue with Calc to the autosave feature. I have a spreadsheet that is opened from a network shared drive (I don't know if this is relevant to the issue but who knows). LibreOffice freezes when it attempts to autosave the spreadsheet. I cannot do anything with Calc at that point as it is completely unresponsive. I can't close it and I have to use Task Manager to exit LibreOffice entirely - of course, all of my changes are lost. I've noticed that Task Manager shows LibreOffice using 30% of my CPU at this point. I have attempted to wait it out hoping that LibreOffice is doing something in the background but after 5 minutes or so, I have lost my patience. The only way around this is to disable the autosave feature. Any ideas on how to fix this?

edit retag flag offensive close merge delete

Comments

Which LibreOffice version, which platform, which kind of network shared drive, does it happen only with this one document, is it reproducible with other documents, does it happen when the document is not on a shared drive, is the network share by chance waiting for some user interaction, does the document contain macros that kick in when saving, if so what do they do, ...

Too many open questions for a crystal ball.

erAck gravatar imageerAck ( 2018-11-07 15:56:58 +0200 )edit

Using latest version of LibreOffice. Windows 10 64 bit and it also occurs on a Windows 7 64 bit platform, both are up-to-date. So far, I have seen this behavior with only this one document. There is nothing unusual about the NAS setup. The document has no macros. It is password protected. I have not done extensive testing and my question was an attempt to save myself a lot of testing time.

PS25 gravatar imagePS25 ( 2018-11-07 22:44:32 +0200 )edit

Oh no! Sympathy. The stuff of nightmares. This is why I keep several copies of important projects with revision dates in the filename in case something like this happens. I'm also paranoid and usually turn off auto-save features so I can choose when to save manually. Graphic intensive programs are notorious for crashing, so I guess that's where my practice came from. Working on something like a spreadsheet or database... you don't want to lose all that impossible-to-recreate work!

PhLo gravatar imagePhLo ( 2018-11-08 10:58:27 +0200 )edit

I'll accept sympathy at this point. Thank you.

I have done more testing. I opened the document that is giving me heartache and added some minor changes to trigger the autosave. I left it open and created a new document that I saved with a password but left open. I waited. I went back and played with both documents without a problem. I closed both and opened them both again and made minor edits. I waited. No problem.

I have gone back to disabling the autosave.

PS25 gravatar imagePS25 ( 2018-11-08 15:43:27 +0200 )edit