Ask Your Question
0

(Answered) Comparing password-protected documents does nothing.

asked 2018-11-12 17:37:41 +0200

Breagha gravatar image

updated 2018-11-12 23:21:28 +0200

In Writer, when I try to compare two versions of the same password-protected document (i.e. same password), nothing happens.

I open the first one, get prompted for the password, go to Edit -> Track Changes -> Compare Documents and choose the second version. I get prompted for the password again, I type it just like the first document. And then nothing happens. I wait for a couple of minutes, then second-guess myself and check word count on both documents.

The documents don't contain the same amount of words nor characters, and they are of different sizes. Something should have happened.

I am currently using Version: 6.1.3.2 (x64) but I've not had any luck with comparing password-protected documents in any version. I've only had need of this for password-protected documents since after version 6 was released, so I don't know if it worked in previous versions.

Am I doing something wrong, or is this a bug? Is there a work-around?

edit retag flag offensive close merge delete

Comments

So, I'm using Ubuntu 18.04 and LO 6.1.3.2 and just tried this with the same results - it asks for the password and then does nothing (even though I specifically made the two files with slightly different text). Looks like a bug. Checking the issue tracker just now I can find no entry however.

Would you like to open an issue on the bug tracking system? (I can do so if you prefer, but if you do you will get notifications as the issue is worked) Let me know if you prefer me to do so however.

DrewJensen gravatar imageDrewJensen ( 2018-11-12 21:32:30 +0200 )edit

BTW I just tested this with versions back to 5.4 and none of them work - asked on the QA channel at LO about this just now.

DrewJensen gravatar imageDrewJensen ( 2018-11-12 21:42:07 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-11-12 22:15:46 +0200

DrewJensen gravatar image

updated 2018-11-12 22:16:12 +0200

Turns out this an old bug and already had an issue opened for it, under the component Calc. The issue has been updated to address all LibreOffice files and two test Writer files added. If you have an account on the Issue Tracker system you can, if you so choose, add yourself to the CC field and get updates on any progress.

Until then the only work around I can think of is to save each of the files to a new file without password protection turned on.

The issue URL is: https://bugs.documentfoundation.org/s...

edit flag offensive delete link more

Comments

Well - changing component wasn't correct, since, as the bug description mentioned, Writer has own tdf#41493.

Mike Kaganski gravatar imageMike Kaganski ( 2018-11-12 22:53:15 +0200 )edit

well, one of the folks on the QA irc channel thought it was good idea just to change to component LibreOffice since it is the same error in both Calc and Writer - but I do not mind walking the changes to the Calc specific issue back.

DrewJensen gravatar imageDrewJensen ( 2018-11-12 23:14:21 +0200 )edit

Thanks a lot for checking this on other versions - and for your very quick reply. And for looking into it. I'll go add myself to CC.

I'll copy+paste until it's fixed.

Breagha gravatar imageBreagha ( 2018-11-12 23:20:06 +0200 )edit

OK, but you want to follow the issue posted by Mike above, as I'm reverting the one I touched back to the Calc component.

DrewJensen gravatar imageDrewJensen ( 2018-11-12 23:22:19 +0200 )edit

Also also - is there a button I press to have the topic answered, or is it enough to just change the title?

Breagha gravatar imageBreagha ( 2018-11-12 23:22:46 +0200 )edit

I'll go to Mike's link, thank you :)

Breagha gravatar imageBreagha ( 2018-11-12 23:23:16 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-11-12 17:37:41 +0200

Seen: 88 times

Last updated: Nov 12 '18