Ask Your Question
0

French grammar

asked 2018-11-17 11:29:29 +0200

axlbrose gravatar image

For French text, grammar errors are not detected, also punctuation is incorrectly generated, e.g. a colon ":" should appear with a space in front of it, but doesn't. Text language is set to French, but when I open spell check, the Language is listed as "none" and doesn't allow me to make a selection. And yet French spelling mistakes are detected. Please help!

edit retag flag offensive close merge delete

3 Answers

Sort by » oldest newest most voted
0

answered 2018-11-18 13:54:05 +0200

BigRAl gravatar image

This LO extension may be of some help.

edit flag offensive delete link more
0

answered 2018-11-17 16:39:20 +0200

gabix gravatar image
edit flag offensive delete link more
0

answered 2018-11-17 11:58:50 +0200

ajlittoz gravatar image

updated 2018-11-17 12:01:51 +0200

As far as I know, there is no French grammar checker in out-of-the-box installations, either from distro package or from LO repository. There might be extensions for it, but I didn't check.

When you open the spell checker, language indication in the drop-down menu set to None does not really matter as long as the paragraphs or sequences of characters (with character style) are correctly "typed". The fact that you get no automatically added space between a word and a colon is a sign that something is not properly set in your configuration.

First, see in Tools>Options, Language Settings>Languages which defaults apply. Section Default Languages for Documents defines initial conditions. You have two options with Western: either you leave it at Default - French (<some country>) which will use your system locale or you force it with French (<some country>).

Second, check if paragraph style Default Style overrides this setting. Go to the styles side pane with F11. Right-click on Default Style and choose Modify. In the Font tab, drop-down menu Language tells you which language is the default to apply to any paragraph style. If you don't read French, push Standard button (the rightmost one at the bottom of this dialog) to restore settings from Tools>Options.

All paragraph styles inherit from Default Style. If no other one overrides the language setting, you're fine. Otherwise, you'll have to find which is the culprit. Usually, main text is style Text Body. Check this one as you did for Default Style.

Once language is properly set, AutoCorrect should give you automatic space insertion. If this is still not the case, have a look at Tools>AutoCorrect>AutoCorrect Options, Localized Options tab. For French, you have a pair of check boxes for Add non-breaking space before specific punctuation marks in French text. They should be checked.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-11-17 11:29:29 +0200

Seen: 50 times

Last updated: Nov 18 '18