Ask Your Question
1

Autocorrect: Do not capitalize the first letter of mRNA, tRNA, iPhone, fMRI at the beginning of a sentence

asked 2018-11-28 18:13:27 +0100

baziliscus gravatar image

updated 2018-11-28 18:18:15 +0100

How do I stop autocorrect from changing the first letter of these abbreviations to uppercase at the beginning of a sentence?

edit retag flag offensive close merge delete

Comments

Mike Kaganski gravatar imageMike Kaganski ( 2018-11-29 07:39:50 +0100 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2018-12-07 14:00:26 +0100

Implemented for 6.3. There, the utility of list for words with two initial caps is extended to also include words with small initial characters.

edit flag offensive delete link more

Comments

Cool, thanks! I just installed the current version in the hope that you meant 6.1.3 rather than 6.3, but you did mean 6.3... I'll wait.

baziliscus gravatar imagebaziliscus ( 2018-12-07 14:47:11 +0100 )edit

Yes, you are right :-) - I really meant 6.3 due to be released in next august (I have just pushed the change; you may see that in the bug I filed for you and mentioned in the comment to your question).

Mike Kaganski gravatar imageMike Kaganski ( 2018-12-07 15:08:30 +0100 )edit

Nice. Thanks for all that work you do! There's a suggestion for a workaround on the bug page: "tommy27 2018-12-05 09:48:31 UTC: makes sense. valid enhancement request. in the meantime a workaround is to put some specific autocorrect items such as "IPhone -> iPhone" and "FMRI -> fMRI" etc. etc." I just tried that, and it does not work for me. "Capitalize first letter of every sentence" wins.

baziliscus gravatar imagebaziliscus ( 2018-12-07 15:23:18 +0100 )edit

and it does not work for me. "Capitalize first letter of every sentence" wins

Confirm.

Mike Kaganski gravatar imageMike Kaganski ( 2018-12-07 15:30:06 +0100 )edit
0

answered 2018-11-29 05:52:13 +0100

robleyd gravatar image

Try Tools | AutoCorrect | Options and uncheck whichever options associated with Capitalise first letter of every sentence you want to disable.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. If this resolves your problem, close the question, that will help other people with the same question.

edit flag offensive delete link more

Comments

I see that I can uncheck "Capitalize first letter of every sentence" but that's not what I want. I do want AutoCorrect to capitalize the first letter of every sentence, except in special cases like mRNA or fMRI. It looks to me like LibreOffice can't handle that. (Some think such abbreviations don't belong in the beginning of sentences anyway. I disagree though.)

baziliscus gravatar imagebaziliscus ( 2018-11-29 10:34:25 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-11-28 18:13:27 +0100

Seen: 70 times

Last updated: Dec 07 '18