Ask Your Question
0

master document

asked 2018-12-06 15:05:15 +0100

capemayal gravatar image

I have a master document with base subdocument/report. The base report is not updating the fields after changing the records in base. I don't know what I'm doing wrong.

Any advice appreciated.

Al

edit retag flag offensive close merge delete

Comments

Hello,

Please be more specific as to what you have and what results you expect. For example, are you talking about a report generated in Base (Report Builder)? Are you dealing with fields in Writer linked to Base records? Also include OS & LO version.

Ratslinger gravatar imageRatslinger ( 2018-12-06 19:04:27 +0100 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2018-12-06 19:46:53 +0100

Ratslinger gravatar image

Hello,

A report generated in Report Builder in Base does not contain links back to the originating data. Once generated there is no connection back to the table(s)/queries(s) containing the data. If the data is changed, the report must be re-created. It is akin to copy/paste. If the original changes you need to redo.

For what it appears you are attempting, possibly a mail merge is needed in Writer or some use of 'fields' linked to the DB to generate you final MD. Exactly what you may need to do and how to proceed will largely depend upon how you are set up (Base & Writer) and the final result. A look at the LO Writer docs may help especially in the mail merge chapter -> LibreOffice Writer Guide

edit flag offensive delete link more
0

answered 2018-12-06 19:28:26 +0100

capemayal gravatar image

Thank. Didn't think about your question.

The Base report is using Base's report wizard. To use design mode can't be used (choosing does nothing).

The database is for a friend's medical history - meds, vaccines, etc.

I made a Writer master document with a table at the top for name, address, etc.

I have only put one report into the master document. I have been able to eliminate the page break between the MD's 1st page and the report on the second page, so that information flows on the same page.

The problem is that when I change data in the database - e.g., medication name, number of doses and strengths, that the info is not updated in the MD when I open it. I do select to update data when opening the MD.

My expectation is that the data would be updated to agree with the database changes.

The only way I've been able to do it, so far, is to save the base report as a copy again, which brings back the page break problems, etc.

So, that's my problem.

Thanks.

Al

edit flag offensive delete link more

Comments

@capemayal, this is not an answer. Answers are for actually answering the original question. Please use add a comment or edit original question for this type of response.

Ratslinger gravatar imageRatslinger ( 2018-12-06 19:34:07 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-12-06 15:05:15 +0100

Seen: 42 times

Last updated: Dec 06