Ask Your Question
1

Table of Contents Formatting

asked 2018-12-06 16:11:50 +0100

Dawud gravatar image

I have a document which is written in English and Arabic. The table of contents has been giving me a hard time. When I try to edit/set the style, it only seems to change the font of the English and not the Arabic. I am using the Arabic font for both the English and Arabic throughout the entire document. The font is Arabic Typesetting. For some reason the actual arabic text will stay on Tahoma font and other formatting aspects will also not change such as size, boldness etc.

For example,

The types of اَلْمُفْرَد/ اَلْکَلِمَة (singular words)........ 12

The English will accept the change in its formatting and apply it throughout the table of contents but any Arabic will keep its default. It doesnt matter whether they are together or isolated. If I make a manual change to the Arabic, it will work until I update the index. It then goes right back to the Tahoma default. I also noticed that when I click on both an English word and an Arabic word, they both display the same style in the box but will show different fonts in the font selection box.

I would appreciate any help. Thanks in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
3

answered 2018-12-06 17:03:05 +0100

ajlittoz gravatar image

Remember that a TOC is a dynamic element: it is generated by LO Writer. As a consequence, any manual change you could make directly on the TOC will be lost when tables are updated.

The "correct" way to change formatting in a TOC is to play with paragraph styles Contents n where n reflects the level of the entry.

Since you write both in English and Arabic, I assume you enabled Complex text layout in Tools>Options, Language Settings>Languages. When this is done, you can define your default fonts in Tools>Options, LibreOffice Writer>Basic Fonts (Western) and Basic Fonts (CTL). For TOC, the default choice is set in Index line.

But, if this is not satisfactory in all circumstances, you can be more specific. Open the styles side-pane with F11 and look for styles Index and Contents n.

The changes you make in Index will also apply to Contents n (unless you override in a specific style).

Let's say you only want to customise a particular level, like Contents 2. Right-click on the name and Modify. Go to Fonts tab. You'll find there the settings for the runs in English and for those in Arabic. Change to your liking and press OK.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Comments

شُكْرًا Thank you very much. That solved the issue. I'm new to word processing so this was a very valuable lesson.

Dawud gravatar imageDawud ( 2018-12-06 17:09:35 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-12-06 16:11:50 +0100

Seen: 33 times

Last updated: Dec 06