Ask Your Question
0

How to reset table of contents settings for individual document

asked 2018-12-08 16:10:37 +0100

John99 gravatar image

updated 2018-12-08 18:48:16 +0100

I am trying to fully reset the Table Of Contents settings for an individual document. How do I do that please?

Edit about an hour after posting. I am revising to use a shorter file almost a reduced test case. I will leave the original screenshots but add new ones for a shorter file which I will then attach. 2nd Edit Using the file I attached I have opened that in another account in Writer and deleted the original ToC and added fresh ones. Those look as expected. They do not try to index themselves. I have added a screenshot of expected results.

I note the Reset options on individual panes as I edit a ToC but those do not seem to fully reset it, or if they do it requires individually resetting everything and there are quite a lot of tabs and options to work through.

Thanks in advance for anyone tryng to assist with this. The issue itself that prompts me to write this question is that Tables of Contents are indexing their own content. So if I do a ToC of the whole doc and a ToC to say level 3 the level 3 ToC is picking up some of the internal ToC and indexing that. If I then create another ToC to level 3 and leave that as editable in an attempt to troubleshoot that indexes the first level 3 ToC.

My profiles location does not contain any templates folder, so as far as I am aware no custom template is in use. I did edit the ToC settings to add a coloured background to some of the headings, but that has not caused issues with other files. Other documents on the same computer account do not seem to display this unexpected behaviour. I will attach a screenshot of the ToC s

Revised screenshots relating to attached test file generating unexpected results This ToC includes index of its own content This Full ToC also indexes from within Note in these screenshots the numbers to the left are ones I have added by way of explanation/confirmation of header levels. Any numbers to the right are generated by the Table Of Contents. Hopefully I can attach the short test file I used.example-toc-issue.odt

EXPECTED result. Test file with new Table of Contents same-example-new-toc

Original Screenshots these may be ignored 1st ToC 2nd ToC including indexing of the first ToC

An answer relating to WINDOWS will probably suffice as that is probably more popular and will no doubt help me resolve this issue. I am currently using Libre Writer v5.2.7.2 on Linux (Debian) but also read, write and edit Libre Writer files on Windows 7 & 10 and even on Android using the Viewer App experimental feature.

This is a rather trivial issue on the current document, but I have several documents that run to hundreds of pages and I do not want this issue to start affecting them, something that could potentially occur If I am unable to resolve and understand this problem.

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2018-12-08 16:36:38 +0100

ajlittoz gravatar image

updated 2018-12-09 10:54:25 +0100

From analysis of your sample document, you apparently modified a critical parameter in tab Outline & Numbering of styles Contents 2 and Contents 3. This parameter is Outline level. It is a kind of flag telling Writer that the corresponding paragraph is a heading and at which level in the hierarchy (chapter, sub-chapter, …) it belongs.

When a TOC is requested, Writer scans the document for such flagged paragraphs and associates them with the corresponding level in the TOC.

Since you marked Contents 2 and Contents 3 as level 3 and 4 respectively, they will be picked again in the second and subsequent TOCs.

To fix the problem, just revert Contents 2 and Contents 3 to outline level Body text.

Remark: you apparently want to have TOCs at head of chapter. You can do that be limiting the scope of TOC scanning by choosing Chapter in Create Index or TOC section of the TOC dialog. But for Writer a chapter is anything between Heading 1 paragraphs. You should then use Heading 1 instead of Heading 2 to bound your chapters.

(Your comment deleted, because it is no longer relevant after my editing of this answer.)

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Comments

Thanks for the revised reply. I will look again at how my problem document was set up.

Thanks for the tip about Indexing, chapters, Although that was something I was aware of. What I usually do is creatre two contents tables: one indexing the entire document all levels, and one indexing only two or three levels.

You did not explain how I am able to clear / reset table of content settings. I pressume there must be some method of doing that, and I hoped any such method may provide me a quick resolution to this sort of problem.

I do not have time to look at my problem document and your answer in detail right now. Your reply appears to explain the situation, and I wanted to thank you for the answer. I will mark it as a solution after I have looked over the information more closely.

John99 gravatar imageJohn99 ( 2018-12-10 23:33:24 +0100 )edit

Well, there isn't really a way to one-click reset TOC settings. Visual aspects are handled by Contents n styles family. Layout is controlled by Insert>TOC & Index>TOC, Index or Bibliographymainly in Type and Entries tab.

ajlittoz gravatar imageajlittoz ( 2018-12-11 09:25:29 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-12-08 16:10:37 +0100

Seen: 39 times

Last updated: Dec 09