Ask Your Question
0

Where is the transpose operation on clipboard in LO 6 [closed]

asked 2018-12-13 23:44:03 +0100

matm gravatar image

updated 2018-12-25 19:30:46 +0100

erAck gravatar image

I'm using LO Version: 6.0.7.3, Build ID: 1:6.0.7-0ubuntu0.18.04.2

In Calc, I want to transpose some data following the help procedure. When I select Edit>Paste Special, I got a Paste Special dialog which looks like an external data import dialog: image description

and then

image description

but I see no options to transpose like the Paste dialog shown here

Can someone confirm

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by erAck
close date 2018-12-25 19:30:59.994468

2 Answers

Sort by » oldest newest most voted
0

answered 2018-12-16 20:04:45 +0100

erAck gravatar image

My assumption: you are using a system clipboard intervening breaker (aka "manager") that is dumb enough to offer only text to the receiving target application, effectively discarding all other possible source formats.

edit flag offensive delete link more

Comments

It looks like Parcellite lacks the support to paste current clipboard entry in its native format. Thanks

matm gravatar imagematm ( 2018-12-22 15:27:49 +0100 )edit

CopyQ has a Disable clipboard storing function which allows to copy and paste as expected.

matm gravatar imagematm ( 2018-12-22 23:21:33 +0100 )edit
0

answered 2018-12-14 00:51:58 +0100

Lupp gravatar image

updated 2018-12-16 19:25:28 +0100

You only get the dialoge you expected if the copied source was a range of a spreadsheet under the same LibO desktop. If the source is external (a different application or a second instance of LibO / soffice) Paste Special... prompts for the selection of a flavour supported by the clipboard due to the preceeding Copy operation (in your case no choice) and the option Unformated text brings up the same (or very similar) dialogue as you get when importing from a file (csv eg) or when using Text to Columns. This dialogue doesn't offer options for calculations or transposition.
Paste your data untransposed and transpose them in a second step with an internal Copy / Paste Special... sequence.

===Attaching an image concerning the comments below 2018-12-16 19:20 CET===
Paste Special... dialogue

By the way: There is also a TRANSPOSE() function. It must be entered for array-evaluation and does not move formats.

edit flag offensive delete link more

Comments

My data came from a copy/paste from internet. I fixed the layout, then copy, then paste in a new sheet, with no luck.

I then tried with manually entered data in a new file, with the same results (the screenshot show this ( dhfk , etc are not copied from internet but typed by me)

matm gravatar imagematm ( 2018-12-16 18:57:27 +0100 )edit

Well, I cannot test with ubuntu currently, but would suppose the options dialogue for Paste Special... should be very similar as on Win systems if the data were copied from a SheetCellRange under the same StarDesktop. It was not changed substantially for a long time now.
What your image shows is the respective dialogue opened when trying to Paste Special... contents from an external source or, probably from a Writer document.
If you actually get this dialogue with a cellrange in the clipboard, it might probably be due to a corrupted user profile - or a problem with the OS settings.

Lupp gravatar imageLupp ( 2018-12-16 19:15:17 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2018-12-13 23:44:03 +0100

Seen: 55 times

Last updated: Dec 16 '18