Ask Your Question
0

LO 6 doesn't save class path

asked 2018-12-17 07:35:05 +0200

z3dom gravatar image

updated 2019-03-22 11:44:45 +0200

I upgraded to LO 6 version.
I have to add Java connector class path,
so I go to OPTIONS->ADVANCED->CLASS PATH and
add there new path to my file "mysql-connector-java-5.1.45.jar".
In previous versions this way works properly, but in sixth I restarted LO and
there is no any paths in OPTIONS->ADVANCED->CLASS PATH.
I added it again, restarted and just get the same clear list.
Can I write my path manually to some configuration file or put my jar file to some special folder?

P.S. Before this trouble happened, I reinstall my Ubuntu to SSD disk and then mount my old HOME folder from old HDD disk like a new HOME folder. (So I moved system to SSD and mount old HOME folder). May be there is some problem with access rights?

edit retag flag offensive close merge delete

Comments

I completely removed LO6 (with -purge etc.) and install LO 5.4 and, the magic, my jar file was already added to class path. So I think there is some user profile file which saved from 5.4 version and after I upgraded to LO6 something went wrong.

z3dom gravatar imagez3dom ( 2018-12-19 09:35:33 +0200 )edit

But there is no Java in LO 5.4...

z3dom gravatar imagez3dom ( 2018-12-19 09:36:48 +0200 )edit

If you don't see Java, either an incorrect one is installed or Base doesn't know where it is (need to 'Add').

Ratslinger gravatar imageRatslinger ( 2018-12-20 04:38:51 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-12-17 18:18:32 +0200

Ratslinger gravatar image

Hello,

Having MySQL for a few years now, have not seen any problem as such. I have kept my .jar files (have a variety for testing) in a folder on my /home directory ('MySQL' folder is what I use - original huh?). Have been using in LO versions 4.x through 6.1.3.2 without problem.

You may way to try resetting you user profile. See -> LibreOffice user profile. Something may have gone awry causing the problem.

edit flag offensive delete link more

Comments

Unfortunately, resetting user profile doesn't help. In safe mode I have the same problem.

z3dom gravatar imagez3dom ( 2018-12-19 09:13:33 +0200 )edit

Have no other thoughts on this. Probably best to file bug -> Bugzilla

Ratslinger gravatar imageRatslinger ( 2018-12-19 17:56:13 +0200 )edit
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2018-12-17 07:35:05 +0200

Seen: 116 times

Last updated: Mar 22