We will be migrating from Ask to Discourse on the first week of August, read the details here

Ask Your Question

All documents given "open by unknown user" error [closed]

asked 2018-12-17 12:42:16 +0200

CutlerIT gravatar image

updated 2020-08-06 22:20:41 +0200

Alex Kemp gravatar image

I have installed Libre Office on a Windows Server 2008 R2 with Remote Desktop Services installed.

Every document that is tried to be opened by a non-admin user gives the error message that it is open by unknown user and only gives me the Read Only or Copy option.

The only way I have found to get rid of this error is to give the Everyone Security Group modify access to the file, obviously I cannot do this for all files.

What would be the global fix for this?

I am still looking around for solutions.

Any help would be much appreciated.

EDIT: if I make the user account a member of Domain Administrators then the error does not happen - obviously I cannot do this either.

Thanks, Christian

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2020-08-06 22:21:33.386193

1 Answer

Sort by » oldest newest most voted

answered 2018-12-17 13:10:32 +0200

CutlerIT gravatar image

updated 2018-12-17 15:22:04 +0200

The are no ~lock-xxx files anywhere and I have edited main.xcd to make the three entries relating to file locking set to false.

EDIT: sorry, I should have mentioned that by doing that didn't resolve the issue

EDIT2: I didn't immediately realise that I had added this an answer

edit flag offensive delete link more


Great that you have answered your question. Please also don't forget to mark it as the accepted answer. Thanks!

Mike Kaganski gravatar imageMike Kaganski ( 2018-12-17 13:12:10 +0200 )edit

My comment was intended to emphasize that Answers are to answer the original question. Whatever additional information you'd like to provide, should go to the question (edit it), not to answer.

Mike Kaganski gravatar imageMike Kaganski ( 2018-12-17 15:11:59 +0200 )edit

I have finally found the solution that works for me, in Tools / Options / Advanced / Expert Configuration I can disable file locking and it works for my scenario.

CutlerIT gravatar imageCutlerIT ( 2018-12-18 10:32:46 +0200 )edit

Question Tools

1 follower


Asked: 2018-12-17 12:42:16 +0200

Seen: 903 times

Last updated: Dec 17 '18