Ask Your Question
0

No JRE but it is there ...few days ago I

asked 2018-12-27 14:29:00 +0100

GreenhornHere gravatar image

updated 2018-12-27 22:41:44 +0100

...few days ago I installed the LO and created Table from Base with the help of Wizard . many entries . After help from this forum I was able to print that out on labels and save it as PDF. In meantime I deleted something important (even from trash). So I did restoration of my PC to previous time . Now I had to install the LO again. After successful installation I try to open table in base I did before the restoration as sample (just 4 lines with few columns) .Now I am getting that there is no JRE installed . SQL Status: HY000 No Java installation could be found. Please check your installation I looked in the Tools - Options - Advanced ...and there is- Java Options is Checked ..JRE already installed ...and the big window is empty. I was trying to do a new Table from Base and I am getting the same results ..

LibreOffice requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - LibreOffice - Advanced.

SQL Status: HY000 No Java installation could be found. Please check your installation

And I just reinstalled the Java application ... again - after first deleting it - I downloaded it from Oracle

Anyone who may help ...Thank you

edit retag flag offensive close merge delete

Comments

1

Have a look at this answer.

ebot gravatar imageebot ( 2018-12-27 15:42:14 +0100 )edit

Hi I have pc windows 64 OS -anyway ...right now I am able to open only the old .odb file - when I open this one - double click - LO Base window pop up - with column on the left : Tables,Queries,Forms,Reports . When clicking on each of them -in Task section is What can be done here - except when clicking on Tables there is also Ikon with my file in the Tables section .I was hoping if i will now in DataBase click on Tables and in the Task click on Use Wizard To Create Table .. I would be able to create one. This warning pop up instead : "LibreOffice requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - LibreOffice - Advanced." So now try to do New Database.

GreenhornHere gravatar imageGreenhornHere ( 2018-12-27 17:52:32 +0100 )edit

Clicked on File - New - DataBase - here pop up window with DataBase Wizard and two Steps to do -Create New DB embedded HSQLDB or Firebird - chose the HSQLDB and click next . Save and Proceed - check the Register and check the Open for Editing also check the Create table using the Wizard . Click Finish and saved on desktop. immediately pop up warning window as before ; "LibreOffice requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - LibreOffice - Advanced." Click OK and another window pop up with : "The connection to the data source "my new file" could not be established.No Java installation could be found. Please check your installation." It seems to me the PC and the Software do not communicate with each other well.It's frustrating because I was able ...(more)

GreenhornHere gravatar imageGreenhornHere ( 2018-12-27 18:01:31 +0100 )edit

FORGOT to mention Windows 7 Profes. 64 OS

GreenhornHere gravatar imageGreenhornHere ( 2018-12-27 18:12:12 +0100 )edit

aaha - now while reading others responses to same issue ..in the Advanced I do have the option to check the Java Options ...BUT in the window under it which say Vendor,Version and Features.. THERE IS NOTHING ..empty ...how can I get there something like Oracle corp. with number of the version ??? PLEASE any one

GreenhornHere gravatar imageGreenhornHere ( 2018-12-27 18:22:52 +0100 )edit

OK in desperate mood - now I downloaded LibreOffice_6.0.7_Win_x64 and deleted the LO 6.1.4.2 ( which should be for the technology enthusiast which I am not). After successful instal went to see IF the JRE is installed differently this time .NO is NOT . The box is checked but in the window under it there is NOTHING as in the previous (better newer ) version of LO . Now I can NOT open even the old one - which worked in the prev.vers. ...lets do it again. delete this one and get the one for "smarter guys"

GreenhornHere gravatar imageGreenhornHere ( 2018-12-27 19:21:56 +0100 )edit

..now I deleted the LibreOffice_6.0.7.3 and reinstalled the LibreOffice_6.1.4_Win_x64 I went to the Advance to see if there is any change ...NOT at all - JRE is checked and nothing in the window under it. Now lets try open my old one file ... and it works - it is open - now let's try to have NEW one table - click on Use Wizard... and warning window pop up again : "LibreOffice requires a Java runtime environment (JRE) to perform this task. The selected JRE is defective. Please select another version or install a new JRE and select it under Tools - Options - LibreOffice - Advanced." Now through the File - New - Database ...NOT WORKING pop up the same as before :" The connection to the data source "hf" could not be established. No Java installation could be found. Please check your installation." I have Java version 8 Update 191 ( build 1.8 ...(more)

GreenhornHere gravatar imageGreenhornHere ( 2018-12-27 19:34:24 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2018-12-27 18:33:51 +0100

Ratslinger gravatar image

Hello,

This is just a Java problem.

First, there are databases which do not require that Java be installed. This may be one you can access already. For the default HSQLDB you need Java installed. But you don't provide the information necessary to guide you. In the link provided by @ebot, the first sentence is:

In the future please provide some minimal info in your question such as OS, LO version & in this case the bitwise of LO & JRE (32 or 64).

and the only item you have provided is the OS.

For your OS, if you have a 32-bit LO version installed you need to install a 32-bit version of Java JRE. If you have a 64-bit version of LO installed then a 64-bit version of JRE is needed. This is the VAST majority of encountered problems with Base & Java - the wrong version installed.

Please verify that the correct version is installed for the LO version you have.

edit flag offensive delete link more

Comments

I do have Win 7 Pro 64 bit OS

and 64-bit Java for Windows Recommended Version 8 Update 191

instaled

GreenhornHere gravatar imageGreenhornHere ( 2018-12-27 19:54:32 +0100 )edit

But, and again missing a bit of info, do you have 32 or 64-bit LO installed? Also where is Java installed on your system?

Ratslinger gravatar imageRatslinger ( 2018-12-27 20:01:34 +0100 )edit

LO Version: 6.1.4.2 (x64)

what I am able to find out JAVA is here : C:\ProgramData\Microsoft\Windows\Start Menu\Programs

I am mostly under the impression that the downloaded program KNOWS where to go it self

From Java Control panel Java Runtime Environment Settings C:\Program Files(x86)\Java\jre 1.8.0_191\bin\javaw.exe ...it is enabled

GreenhornHere gravatar imageGreenhornHere ( 2018-12-27 21:30:09 +0100 )edit

Well, here we are right back at square 1. Java is 32 bit (Program Files(x86)) & LO is 64 bit. You do not have correct Java JRE for LO installed.

Ratslinger gravatar imageRatslinger ( 2018-12-27 21:53:09 +0100 )edit

How did you know ? the x86 is actually 32 and not 64 bit ? When I am most of the time downloading anything as program or update THE SYSTEM itself search / investigate / is sniffing in my PC and then it acts based on what it find out . I thought the same here. Just like I was downloading the LO. THE correct program was there just to click on it. THANK YOU VERY MUCH AGAIN.

One more Q. about the Table. In the old one I have I did not pick column name ID and it is not there. This time I did not pick it up as well but it is there. Can I somehow remove it from the table ? Or how to NOT have it there in first place. I have no needs for it at all.

GreenhornHere gravatar imageGreenhornHere ( 2018-12-27 22:40:28 +0100 )edit

Easy. In Windows you can run 32 & 64 bit programs. 32-bit are stored in 'Program Files(x86)' folder & 64-bit are stored in 'Program Files' folder. Windows will place the program you are installing into the appropriate folder.

As for the table question, not exactly certain what you are referring to. Sounds like a key field. Tables need a key field for access to records. You may not have a need but databases table records need a key field for access. You probably need to review some of the Base documentation.

Ratslinger gravatar imageRatslinger ( 2018-12-27 22:53:36 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2018-12-27 14:29:00 +0100

Seen: 605 times

Last updated: Dec 27 '18