Ask Your Question
0

Why do saved documents (.docx) appear as archives?

asked 2019-01-01 14:41:55 +0100

venik212 gravatar image

I am running Lubuntu 18.10 (with LXQt) and LibreOffice 6.1.2.1. Whenever I save a new file as filename (with the MS format of WORD), it becomes an archive, with the icon of Ark (the archiving app under Lubuntu). If I then rename the file to filename.docx, the icon changes and it looks and functions like a normal LO file. What is going on?

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2019-01-01 15:13:08 +0100

What is going on?

It's likely you have unchecked Automatic Extension in File Save dialog, which makes files not have an extension unless you explicitly provide one; and your file manager, detecting a file which is an archive, assigns "appropriate" type. DOCX is actually a ZIP archive with document content inside as several XML.

edit flag offensive delete link more

Comments

Thanks for the speedy response. I love your theory, but in checking it out, I was unable to find the suspect Automatic Extension check box. Where is it hiding? I am dying to uncheck it!

venik212 gravatar imagevenik212 ( 2019-01-01 18:01:52 +0100 )edit

Well - you never mentioned which WM you use (and actually, the full data from Help->About is what is needed). Also, it's important to know if you use system dialogs or not. All that defines which Save As dialog is used, which affects the checkbox existence and placement.

See e.g. tdf#121418.

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-01 20:02:56 +0100 )edit

I did mention in my original post that I am running Lubuntu 18.10 with LXQT as its WM (replacing LXDE in this cycle). The info you were asking for is: Version: 6.1.2.1, Build ID: 1:6.1.2-0ubuntu1.1, CPU threads: 4; OS: Linux 4.18; UI render: default; VCL: gtk3_kde5; Locale: en-US (en_US.UTF-8); Calc: group threaded.
I found no way to switch from system dialogs to anything else. I just used the LO that was installed by default with Lubuntu.

venik212 gravatar imagevenik212 ( 2019-01-01 22:06:02 +0100 )edit

I did mention in my original post

Ah, you are right.

The information you provided tells that your chosen VCL plugin (gtk3_kde5) might not have the checkbox (if it's like gtk as in the cited bug - can't check myself). In that case, it must add extensions always when there is none provided - do you use dot in the name by chance?

I found no way to switch from system dialogs to anything else

The bug I mentioned contains a workaround, which is just about how to enable LibreOffice own dialogs.

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-02 00:49:27 +0100 )edit

Thank you very much for the help-- following the (inaccurate) guide to the workaround that was mentioned in the bug report, I was able to fix the problem. I had to use the Search in the advanced LO settings to find the right place, but I found it, fixed it, and all is well. Your help is greatly appreciated.

venik212 gravatar imagevenik212 ( 2019-01-03 05:00:40 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-01-01 14:41:55 +0100

Seen: 136 times

Last updated: Jan 01