Ask Your Question
0

How to disable autoconversion of -- into single — ? [closed]

asked 2019-01-17 18:07:05 +0100

Tristan107 gravatar image

updated 2019-01-17 18:17:22 +0100

I went to Tools > Auto correction > Replace tab and I've removed the line

In options, I've also uncheck "Use replace table".

But when I have a "--" between 2 other characters, it's still transformed into single long "—" as soon as I validate the cell.

I've also tried to set the language to "None" in Tools > Options > ...

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by erAck
close date 2019-01-18 20:03:19.401366

1 Answer

Sort by » oldest newest most voted
2

answered 2019-01-17 21:47:18 +0100

libreofficeUser30872 gravatar image

updated 2019-01-17 21:53:49 +0100

It sounds like you have taken all the steps, except:

Tools > AutoCorrect Options > Options > "Replace dashes"

You can have the "Use replacement Table" unchecked, but you still need to uncheck this option.

If this doesn't work, to narrow the problem down when something like this occurs, I close Calc completely, open Calc with a new spreadsheet, and try it. If it works, then I reopen the spreadsheet I was working on to see it the problem still exists.

You didn't say what version of LO you are using. I am using LO 6.1.4.2. I have all the AutoCorrect options turned off and it works as you desire (no conversion).

A work around, to get you going, is to enter the data with a leading tick, like 'a -- b.

It seems like this is a little redundant, since dashes appear in the replacement table and can be removed there.

edit flag offensive delete link more

Comments

Yes, you get it, it was about the redundant option "Replace dashes" after unchecking this, it seems to work.

Tristan107 gravatar imageTristan107 ( 2019-01-18 14:02:39 +0100 )edit

Question Tools

1 follower

Stats

Asked: 2019-01-17 18:07:05 +0100

Seen: 26 times

Last updated: Jan 17