Ask Your Question
0

Typing in non-English Language and then Finding the Language Reset to English When a Heading Style is Applied.

asked 2019-01-28 11:36:48 +0200

StephenM gravatar image

Good Evening

Before I give too many details may I ask if other people see the following behaviour in Writer?

I am using LibreOffice (Version: 6.0.7.3; Build ID: 1:6.0.7-0ubuntu0.18.04.2). My default language for documents is English (Australia).

From time to time I want to type part of a document in another language, let's use Italian for example.

I begin a new line and at the insertion point I select Italian (Italy) as the language and start typing - no problem; it works as I would expect. However, then I decide that I want what I typed as a level 3 heading (for example). I select the text and change the style. Immediately LibreOffice sets the language back to English (Australia) and so my text has the wavy red line telling me I have spelling mistakes.

Is this what I should expect to occur? That is, the language of the text being reset when I change the style to use a heading. I would not expect heading styles to be language-dependent.

If anyone can confirm this is what should happen and give me a logical reason, then I'll have to accept it. Otherwise, I think it's a feature - and a less-than-useful one.

If you do require more details please let me know.

regards Stephen Meatheringham Canberra, Australia

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2019-01-28 11:50:30 +0200

ajlittoz gravatar image

When you identify your paragraph with Tools>Language>something, this is "direct formatting", i.e. an attribute added to those in effect in the current paragraph or character styles. Usually direct formatting takes precedence over the style settings. However, it looks like language is not as "sticky" as other direct formatting: when you apply a new paragraph style, language is reset to the one defined in the style.

My solution is to define ad hoc styles per language. It has the inconvenient to duplicate common styles but it is very reliable. The styles differ only by the Language attribute in Font tab.

I have also defined a character style I call Foreign Quote where I deliberately set language to None in the Font tab. This is handy for short sequences (trade names, abbreviations, proper names, unusual technical terms, …) with the net effect of disabling spell check. Of course, since language is None, you will not be warned if you misspell anything, but that's a catch-all for occasional use of foreign words or sentences in a language I don(t want to bother styles for.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more

Comments

Thanks for your thoughts and confirmation that it's not something strange with my installation. My "workaround" is to put up with the problem and curse slightly when I have to make the change to select another language. As I could be typing in any of half a dozen different languages creating styles for each heading type in each language it wouldn't be particularly useful to define all the extra required styles.

Thanks again.

StephenM gravatar imageStephenM ( 2019-01-29 21:40:50 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-01-28 11:36:48 +0200

Seen: 24 times

Last updated: Jan 28