how to keep exact interline spaces when exporting to epub

asked 2019-01-29 22:18:12 +0100

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

Hello !

I use essentially two personalized styles, which make use of italic and specific line spacing. I have to keep these spaces how they are. But those styles are not recognized by writer2epub, nor the built-in export function, which reports "input output error" and crashes for the whole file, or just ignore the spacing for a small chunk, as does writer2epub.

Originally, I had to convert from a doc file. But I tried to remove what I perceived as troublesome regards to exportation to epub. What solution exist ?

Exemple: image description While it should look like: image description See the specific spaces ? Two styles used: - GCB: spacing 0 behind paragraphes, 0,10 cm below, also between same kinds of paragraph - Partner: 21 behind, 21 below, italic, don't add between same kinds of paragraph

Thanks.

edit retag flag offensive close merge delete

Comments

I was under impression that ePub has nothing to do with paper layout (which Writer and its supported document formats are about)...

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-30 06:49:02 +0100 )edit

I could put an empty line between italic paragraphs and non-italic ones, I know it; but I also want a bit of space between same-style paragraphs, to add reading confort.

evanescente_ondine gravatar imageevanescente_ondine ( 2019-01-30 16:39:45 +0100 )edit