build libreoffice ocurred "Ant does not work"

asked 2019-01-30 02:09:05 +0200

snowmawar gravatar image

updated 2019-01-30 16:22:54 +0200

OS on Virtualbox : Ubuntu 18.04

When I try to build the libreoffice on Ubuntu 16.04 and Ubuntu 18.04, they both occurred "Ant does not work".

I check with ant -verbose, then get error message :

Apache Ant(TM) version 1.10.3 compiled on July 19 2018 
Trying the default build file: build.xml
Buildfile: build.xml does not exist!
Build failed

More information about ./autogen.sh's error message :

checking for ant... /usr/bin/ant
checking if /usr/share/ant/bin/ant works... configure: error: Ant does not work - Some Java projects will not build!
Error running configure at ./autogen.sh line 296.

Somebody know how to create/write the Buildfile ?

edit retag flag offensive close merge delete

Comments

better ask at #libreoffice-dev

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-30 07:00:31 +0200 )edit

Thank for your comment, let me try it.

snowmawar gravatar imagesnowmawar ( 2019-01-30 16:22:12 +0200 )edit