Ask Your Question
0

Horrible Kerning Issue with Non-Monospace Fonts – Zoom Related – Mac

asked 2019-01-30 07:58:34 +0100

njs gravatar image

updated 2019-01-30 08:06:38 +0100

Hello Allo,

I recently switched to LO on my mac again, after having used it years ago. But the same problem that kept me from using it last time is still present – and will keep me from using it this time as well, if I can’t solve it with your help. I’d really like continue working with LO though.

The problem has been addressed here and there already, but I could not find a solution anywhere:

The font display in LO has horrible kerning at smaller zoom levels – well, actually at regular zoom level. If zoomed in very close, there is no kerning issue at all. The more you zoom out, the worse the kerning gets.

It is demonstated best with two screenshots:

Text at 110%:

image description

Text at 250%:

image description

You’ll see the difference …It drives me mad, especially as a typography lover.

I can’t really use LO with this kerning. The 110% zoom level is a good working size for me, at 250% it is much too large: one line of text fills my entire 27" screen.

Tech specs:

I’m on a macbook pro 15" early 2013 using OS X 10.11.6 (El Capitan).

The screen from the screenshots is a 4k 27" monitor and the issue occurs also on my retina display – it is no resolution error for sure!

I use LibreOffice 6.0.7.3. and did also try the newer, less stable version 6.1.4. with the same issue.

The font shown in the screenshots is Junicode, but the problem occurs with any font (tested: Times NR, Calibri, Garamond Premier Pro) except with monospace fonts (tested: Courier) – so that might be a hint to the nature of the problem!?

The screenshots were taken from the LO Writer, but the issue occurs also in Impress and Calc.

Any help would be much appreciated! Please don’t hesitate to ask for more information if required.

Thanks, Nicolai

P.S.: If you had the same problem and did not find a solution yet, I would also be thankful for an alternative that works on mac – except MS Office, which I’d really like to stop using!

edit retag flag offensive close merge delete

Comments

and the issue occurs also on my retina display

Could you please share a 1:1 screenshot on HiDPI, so that the issue could be zoomed in and seen at pixel level?

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-30 08:16:24 +0100 )edit

Thanks for your reply. I’m not sure if I understood you correctly, here is what I did: I took a screenshot on the retina display of the whole screen. The picture was taken as a tiff. I cut the top and bottom menu bar in photoshop and saved without compression. As that left me with quite large files, I uploaded them to my private cloud, you can access them here: https://app.box.com/s/8coz3y3pu4bbd2k...

njs gravatar imagenjs ( 2019-01-30 08:43:39 +0100 )edit

Thanks; yes, you did that right. I was asking to see if the problem is there because of some reason other than tdf#103322; and no, there's no other reason - it's that, and it still waits for resolution unfortunately. It's the absence of sub-pixel positioning in LO.

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-30 09:18:49 +0100 )edit

Thanks! Seems to be really complicated from what I understood …

I hope some good person finds a way and time to fix it, because the way font is displayed atm is really bad for a text writer. I myself can’t work with LO that way, which is really a pitty.

As I understood it, the problem exists on all OS? If so, it is hard to believe that this is not a huge topic, as many persons must have this issue!?

I will try to use LO 5.2.5. as one comment in the bugreport said that only later versions have the issue. I will report.

Thanks again

njs gravatar imagenjs ( 2019-01-30 10:28:23 +0100 )edit

Same problem zooming on LO Calc files made with the Japanese version (6.1.xxx).

pa gravatar imagepa ( 2019-08-13 17:53:15 +0100 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-01-30 10:50:04 +0100

njs gravatar image

updated 2019-01-30 10:54:32 +0100

Solution/Alternative: Downgrade to LO 5.2.5.

As announced in the comment above, I tested if LibreOffice 5.2.5 also had this issue: I does not!

So anyone who has the same problem and can’t stand the horrible kerning might consider a downgrade. Version 5.2.5. does work on Mac OS X 10.11.6 (El Capitan), for other OS I can’t tell.

Here is the screenshot with exactly the same settings at 110% – only in LibreOffice 5.2.5. this time (compare it to the first screenshot in my original post, the difference is tremendous!): image description

Thanks for your help Mike Kaganski, via which I found out about version 5.2.5.

Still, I hope the issue becomes fixed in the current versions soon – I would imagine this to be a major reason for new users testing LO not to continue with it (as it was in the past for me).

I would also like to suggest that a hint could be placed on the download page to version 5.2.5 regarding this issue (if I understood it correctly that all OS and versions after 5.2.5. are affected).

edit flag offensive delete link more

Comments

The 5.2.5 working OK is macOS-only fact, since 5.3 was the version where macOS rendering was unified with other platforms (see Khaled comment).

Mike Kaganski gravatar imageMike Kaganski ( 2019-01-30 10:56:03 +0100 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-01-30 07:58:34 +0100

Seen: 182 times

Last updated: Jan 30