Ask Your Question
0

Background image on page cannot be removed

asked 2019-01-30 14:03:16 +0200

asgmbh gravatar image

Strange thing: In my standard page format template I inserted a custom background-image for testing. After testing was finished I applied colour None to the page format template and deleted this background-image from my disk.

If I now edit the standard page format template and click on "Organize" (Verwalten in German) the file name of this image is still listed as a background-image. Next I applied a default background and applied None as background again. If you close the standard format template and edit it again the name of the background is still listed.

In fact you cannot really deselect a selected background-image. Coming back to the strangeness: If I save the .ott as .doc the background-image is visible although it is unvisible in the .ott.

Any ideas how to really remove the background?

TIA

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
0

answered 2019-01-30 23:46:09 +0200

m.a.riosv gravatar image

Use the navigator to select the image, then you can remove it.

edit flag offensive delete link more

Comments

No, I can't. Zero images, zero objects. There is no way to select the image, because it is in the background of the page resp. in the area where you write. When you click there, you get only the text.

asgmbh gravatar imageasgmbh ( 2019-01-31 08:10:00 +0200 )edit

@m.a.riosv: background images are not listed in the navigator; is this intended design? I think so because the image has no unique location (repeated on every page) and cannot be jumped to unambiguously.

ajlittoz gravatar imageajlittoz ( 2019-01-31 08:34:05 +0200 )edit
0

answered 2019-01-30 14:47:17 +0200

ajlittoz gravatar image

A similar question was asked on the French leg of this site. My conclusion was the same as yours. LO Writer incorrectly dos not remove XML element <draw:fill-image name="xxx"> when you reset background image to none. What is worse is that Writer uselessly duplicates binary data for the image as content of the XML element. I write "duplicated" because there is some kind of image catalog at the start of the file in <office:styles> as elements <draw:fill-image draw:name="xxx"> containing binary data. The "xxx" is the same in the catalog and <draw:fill-image name="xxx"> .

Image binary data is not removed from the catalog when the image is deleted, thus preventing the file size from decreasing as much as it could.

I added these comments to tdf#92796.

edit flag offensive delete link more
0

answered 2019-01-30 14:37:04 +0200

ebot gravatar image

updated 2019-01-30 14:38:12 +0200

Pictures that have been placed in the background can be selected via the "Drawing" toolbar and the "Selection" symbol. Maybe use the right mouse button to select. Then use the "Remove button".

edit flag offensive delete link more

Comments

I tried this when working on the French question. The image vanishes from the side "gallery" but is still present in the file though not reachable through the UI. I explained that in a comment for tdf#92796.

ajlittoz gravatar imageajlittoz ( 2019-01-30 14:49:26 +0200 )edit

I understand.

ebot gravatar imageebot ( 2019-01-30 14:59:26 +0200 )edit
0

answered 2019-01-30 14:31:35 +0200

asgmbh gravatar image

Part 2: To find ANY occurrence of the image I saved the .ott as a Flat XML ODF and opened this file in an editor. There was a tag called "<draw:fill-image draw:name="name-of-file-long-ago-inserted">" followed by about 800 lines of binary data. So I removed this part, saved the file and opened it again in LibreOffice.

Now I had a blue background, which I switched to None and saved it as .ott

Problem solved!? The old .ott was 63.295 Bytes big, the new .ott is now 19.204 Bytes big.

I hope there is an easier way to remove the image than the way described above? Reediting hundreds of files is no fun. ;)

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-01-30 14:03:16 +0200

Seen: 54 times

Last updated: Jan 30