6.2.0 Fails to install on Win 8.1

asked 2019-02-24 06:13:22 +0200

davk60 gravatar image

I have been using LibreOffice for years, I recently changed my Windows 7 to Windows 8.1 but it fails to install. I did a clean install of Windows 8.1.

LibreOffice versions 6.1.5 and 6.2.0 Win_x64 both have the same problem, it gets to the component registration stage and hangs. Cancel fails to work and I have to cancel the installation via Task Manager.

One thing I have noticed is that it seems to run twice even though install is selected via menu (no double click) as the first dialog box flicks onto the screen then a moment later the original dialog is replaced by another and there are two copies of Windows Installer showing in Task Manager.

Are there any logs to show what errors maybe occurring? Also I do notice that after trying to install LibreOffice CC Cleaner shows a number of Missing shared DLL all related to fonts e.g. "Missing Shared DLL C:\Windows\Fonts\Caladea-Bold.ttf"

How do I fix this?

edit retag flag offensive close merge delete

Comments

See this FAQ regarding recording installation logs, and provide one to get a useful further advise.

Mike Kaganski gravatar imageMike Kaganski ( 2019-02-24 07:01:44 +0200 )edit

One thing I have noticed is that it seems to run twice even though install is selected via menu (no double click) as the first dialog box flicks onto the screen then a moment later the original dialog is replaced by another and there are two copies of Windows Installer showing in Task Manager.

That is normal for any MSI. Windows Installer runs in two processes: one as current user, and one under system account (to perform deferred actions).

Mike Kaganski gravatar imageMike Kaganski ( 2019-02-24 07:44:26 +0200 )edit