Ask Your Question
2

Calc 4.0.3.3 cell update takes 12 seconds?? [closed]

asked 2013-06-08 20:51:20 +0200

OldBoricuainLA gravatar image

updated 2015-11-02 03:10:07 +0200

Alex Kemp gravatar image

i have a 1.2 mb spreadsheet. It's all just numbers and references. there are some 10 graphs. (it's a production tracker).

C:\fakepath\PT Graph 2013.ods

when i updated to LO 4.0, the whole thing changed and now it takes about 12 seconds to update anything on the screen. even to enter a single number in a cell.

one desktop with Win XP and 1 gig ram. Laptop with win7 1 gig ram

First, I took all formulas out and it updated in about 7 seconds.

in Graphics Cache i changed "Use for LibreOffice" to 100. in Cache for inserted Objects, made "number of objects 1000. update still took 12 seconds. i reset the user profile, but no change.

then i unchecked ( tools - cell contents - autocalculate ) and updating a cell took 28 seconds.

I can send the file if needed... [PT GRAPH]

update 11 Jun:: loaded LibO 3.6 on XP comp to see if change. no change. just as slow.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-11-02 03:10:23.173186

Comments

Attaching or linking the file would be easiest way to check if this is something your computer specific or not. So please do attach it.

mahfiaz gravatar imagemahfiaz ( 2013-06-09 00:25:50 +0200 )edit

Mahfaz, I'd love to send it, but i dont rank high enough. if you have an email, i can send it... no problem.

OldBoricuainLA gravatar imageOldBoricuainLA ( 2013-06-09 05:20:58 +0200 )edit

You could upload it somewhere, maybe to upload.ee, dropbox, mega or whatever works for you. Or if you prefer mailing, then my username @gmail.com would do just fine.

mahfiaz gravatar imagemahfiaz ( 2013-06-09 20:50:31 +0200 )edit

@OldBoricuainLA - you got some karma now, thus you should have enough to upload a file here as well.

ROSt52 gravatar imageROSt52 ( 2013-06-10 02:31:25 +0200 )edit

@mahfiaz and @ROSt52, i got the file here now... thanks for giving me a hand with it...

OldBoricuainLA gravatar imageOldBoricuainLA ( 2013-06-10 19:02:34 +0200 )edit

3 Answers

Sort by » oldest newest most voted
2

answered 2013-06-11 21:54:04 +0200

m.a.riosv gravatar image

Seems it is an issue with the conditional formatting in "data table" sheet.

Deleting the second to last condition eliminates the issue or at least it is reduced significantly.

edit flag offensive delete link more

Comments

@mariosv , where is the "second to last condition"?

OldBoricuainLA gravatar imageOldBoricuainLA ( 2013-06-11 22:10:04 +0200 )edit

Go to "data table" sheet, Menu/Format/Conditional Formatting/Manage.

m.a.riosv gravatar imagem.a.riosv ( 2013-06-11 23:04:20 +0200 )edit

went and deleted formatting for the last two ranges (R & U) but no change in numbers.

OldBoricuainLA gravatar imageOldBoricuainLA ( 2013-06-12 01:05:06 +0200 )edit

The delay is greatly reduce for me. Removing the CF for the range: Q64:Q67;Q70:Q77;Q80:Q87;Q90:Q97;Q100:Q107;Q110:Q117;I400:P536;I537:K540;M538:P538;M539:O540;I541:O541;I542:J543;K542:O542;L549:P549;L550:O550;I551:O556;I557:L558;M557:O557;M558:P558;I559:P591;I592:O595;I596:J597;K596:O596;M597:O598;I598:L598;I599:P623;I625:P736;I1000:P1136;I1137:K1140;P1137:P1138;M1138:O1138;M1139:P1140;I1141:P1180;I1181:K1181;L1181:P1182;I1182:I1183;I1184:P1195;I1196:J1197;K1196:P1196;M1197:P1198;I1198:L1198;I12

m.a.riosv gravatar imagem.a.riosv ( 2013-06-12 01:39:48 +0200 )edit

Or try removing all conditional format.

m.a.riosv gravatar imagem.a.riosv ( 2013-06-12 01:40:47 +0200 )edit

@mariosv , THIS WAS THE HANDLING. There is something wrong with the workload of generating conditional formatting... something that i was using heavily in my spreadsheet, as visual aid to production measurement... THANKS A LOT FOR ALL YOUR HELP, GUYS!!! I LOVE LIBO!!!!

OldBoricuainLA gravatar imageOldBoricuainLA ( 2013-06-12 05:41:29 +0200 )edit
0

answered 2013-06-11 05:13:25 +0200

ROSt52 gravatar image

I made a test with XP prof / SP3 on LibO Version 3.6.6.2 (Build ID: f969faf)

LibO was open but Calc still closed.

Including clicking the Disable Macro button it took indeed about 10 sec. However I did not perceive this a particularly slow.

What would your regard as fast enough?

How many second per day would you save?

edit flag offensive delete link more

Comments

@ROSt52, 2-3 seconds i can live with. think of a regular user in an office. you say "disable macro button"... you mean you found a macro in this thing? where? how do i eliminate it? one thing i was looking at, separately, was to update all the formulas. i tried it in my laptop under win7, and got the response down to about 7 seconds. the comparison value? 2-3 month ago response to the update in numbers was instant. Zero wait.. only had to wait for updates if i moved graphs around...

OldBoricuainLA gravatar imageOldBoricuainLA ( 2013-06-11 07:10:08 +0200 )edit

@ROSt52, 2-3 seconds i can live with. think of a regular user in an office.

OldBoricuainLA gravatar imageOldBoricuainLA ( 2013-06-11 07:10:30 +0200 )edit

@OldBoricuainLA - 2 -3 seconds would be pretty fast. But if you open 10 files a day its about 100 sec or 1. 5min per day. I opened today about 10 - 15 files.

macro - I did not search for macros. When I opened the file the enable-disable macro question popped up. Could the popping up message create a delay. 1 - 3 sec?

A 50kB Writer file takes about 5 secs and a 100k Calc file takes about 8 sec. This is felt much faster than with MSO files I opened in the past.

Test with XP prof SP3

ROSt52 gravatar imageROSt52 ( 2013-06-11 09:05:09 +0200 )edit

@ROSt52 - the problem is not in opening the file. that's part of the game. the problem is when i want to update one of the cells. even put a number, an integer, in a cell, that the software takes 12 to 17 seconds to take the update/show the change in the screen... An interesting dilema, when i ran into it... thanks for your interest, ROSt52, i appreciate it...

OldBoricuainLA gravatar imageOldBoricuainLA ( 2013-06-11 09:43:28 +0200 )edit
0

answered 2013-06-11 11:17:46 +0200

ROSt52 gravatar image

@OldBoricuainLA - Sorry for leading discussion into the wrong way. I misunderstood. Now I agree with you that 12 sec are too long. This has to be a fraction of a second.

I tested your spreadsheet on my machine:

Condition: Open the file and save onto my machine and opened the file

  • clicking into another cell takes about 2-3 sec until the new cell is selected
  • clicking >trace pre-dependence< takes a bit more than 15 sec until the blue arrows appear
  • changing a number and thus enforcing a recalculation - time recording was stopped after 2 min - did the file lock up? No actions - like selecting a different cell - were possible anymore

I unfortunately don't have a file of a similar size with formulas and charts for comparison. However I feel that there is something wrong with your file.

edit flag offensive delete link more

Comments

Just to add a bit of data: I grabbed the file, opened in LibO Calc [Version 4.0.3.3 (Build ID: 400m0(Build:3))], got the "this file contains macro" warning (clicked "OK"), opened the "data table" sheet, did CTRL-home to get from E2477 ;) to A1, then changed some numbers in column J. Consistently took about 15 seconds for the cursor to move after update. That's slow. This is on a Dell Optiplex 745, Intel Core 2 Duo 6300 @ 1.86GHz 2Gb RAM , running Lubuntu 12.10 (everything runs snappy). FWIW.

David gravatar imageDavid ( 2013-06-11 12:11:21 +0200 )edit

Question Tools

Stats

Asked: 2013-06-08 20:51:20 +0200

Seen: 805 times

Last updated: Jun 12 '13