Ask Your Question
0

Unable to set-up Primary Key Ver 6.2.0.3 (x64) [closed]

asked 2019-03-28 17:50:02 +0200

AndeAnderson gravatar image

In Base, Ver 6.2.0.3 (x64) I am unable to set-up a designated Primary Key with AutoNumber. Help says:

"Include a "primary key" data field. Base needs a primary key to be able to edit the table contents. A primary key has unique contents for each data record. For example, insert a numerical field, right-click the first column, and choose Primary Key from the context menu. Set AutoValue to "Yes", so Base can automatically increment the value for each new record."

When I right click on the Field I get a Standard Context Menu for Undo, Copy, Paste. When I right click on the "Field Name" for the column all I get is "Column Width".

Since that doesn't work, how do I assign a Primary Key with AutoNumber? Thanks

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by AndeAnderson
close date 2019-03-28 19:50:01.437194

Comments

Please, if the answer solves the question click ✔.

m.a.riosv gravatar imagem.a.riosv ( 2019-03-28 22:33:05 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-03-28 18:42:29 +0200

Ratslinger gravatar image

Hello,

First, here is the link to the LO documentation -> LibreOffice Base Handbook. Chapter 3 - Tables should be of help.

Create table in Design View presents first:

image description

Then you enter (based upon using an auto increment key field) a field name and a field type:

image description

Then change AutoValue property to Yes and then select a new line in field names:

image description

you will see the key field is set to left of the ID field. You can always set the field yourself by right mouse clicking that area to left of field name and the selecting Primary Key from context menu:

image description

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2019-03-28 17:50:02 +0200

Seen: 64 times

Last updated: Mar 28