Ask Your Question
1

Adding legalised headings to my document. [closed]

asked 2013-06-18 00:53:01 +0200

this post is marked as community wiki

This post is a wiki. Anyone with karma >75 is welcome to improve it.

I have a roughly 150 page book, where I use HEADING 1, HEADING 2, HEADING 3 and HEADING 4 to divide chapters, sections and subsections etc. I want to add numbers to those headings such as 1, 1.2. 1.2.1, 1.2.1.1 etc.. I also want to update my table of contents so that all of those headings and the numbering are included.

I have figured out that it is done through the tools>outline numbering page, but when i try to add them, I only get the numbering added to either heading 1 or heading 2 etc, and the table of contents only lists whichever heading is numbered.. clearly i am doing something wrong.

I am using Libreoffice 4.0.3.3

Exactly how should the outline numbering page look to accomplish this?

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-02 18:41:31.211872

Comments

Oweng, thanks for your reply, I am now totally confused. I was unaware of the outline and numbering tab viewable through right clicking on a heading and pressing paragraph. When I do that for a heading 2, it shows me that the outline level is 2, and the numbering style is none. Neither field is disabled.

mango gravatar imagemango ( 2013-06-19 00:16:54 +0200 )edit

OK .. fearing I may have really messed up the outline and numbering somehow, I created a new document from scratch, and am trying again. First I have gone to the tools>outline numbering option, and then I have, I believe, followed your basic steps outlined below. This time, I don't see ANY numbers before ANY of the headings, regardless of level. If I edit a heading 2 paragraph, it shows "outline level" as level 2 (but disabled), and numbering style as outline numbering. Please advice?

mango gravatar imagemango ( 2013-06-19 00:41:52 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2013-06-18 08:00:14 +0200

oweng gravatar image

It sounds like you may have used a different form of numbering for the lower level headings at some point. When you edit a lower level heading (e.g., the Heading 2 style), what does it show on the Outline & Numbering tab? It should show Outline level of "Level 2" and Numbering Style of "Outline Numbering" (both greyed out). Also check under the Organizer tab that the heading styles are Linked with the "Heading" style. The fact that not all your headings are showing up in the ToC would tend to indicate that not all are using Outline Numbering.

The basic steps to turn on Outline Numbering are:

  1. Tools > Outline Numbering...
  2. Select Level of "1-10".
  3. Select Number of "1, 2, 3, ...".
  4. Select Level of "2".
  5. Set Show sublevels to "2".
  6. Select Level of "3".
  7. Set Show sublevels to "3".
  8. ... etc ... for all required heading levels.
  9. Click OK.

When inserting the ToC ensure the Create from section has the Outline option checked. If you are using custom heading styles, you may need to check the Additional Styles option and click the adjacent ellipsis button to set the levels of your headings.

edit flag offensive delete link more

Comments

Thing to add: it is needed to also choose a style in the «Outline Numbering» (e.g. «Heading 1», «Heading 2», etc). Anyway, that doesn't work properly. For some reason the style of «Heading 2»s not being restarted for every «Heading 1».

Hi-Angel gravatar imageHi-Angel ( 2015-08-15 23:13:45 +0200 )edit

Funny — that started work properly after I saved the document, and restarted the Office.

Hi-Angel gravatar imageHi-Angel ( 2015-08-15 23:45:18 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2013-06-18 00:53:01 +0200

Seen: 441 times

Last updated: Jun 18 '13