Ask Your Question
0

Endless problems with table in Writer

asked 2019-05-12 20:36:37 +0200

NutZ gravatar image

Hello,

I use libreoffice writer since a couple of years and I haven't had any huge problem with it before but now, since I need to write documents with huge tables in it (tables that goes across multiple pages), I have an endless problem that I just can't fix. In an arbitrary matter, my tables break randomly across pages and sometimes, it leaves 95% of the page blank and just one line of cells on the top of it with 2 not more than 2 lines of text in it (even if the 5 next lines of cells are also just 2 lines and could easily fit on the same page; even if I have tried everything that is possible to try in table properties)...It gets really annoying and make me losing plenty of time. The way the table breaks doesn't seem to have any logic or if it does, I didn't found it yet. Sometime, I will press Ctrl+Z and than retype exactly the same thing and it will make a page break the first time I write it and none the second time (or the other way around).

Anybody has a way to fix that.

I use LibreOffice Version: 6.0.7.3 Build ID: 1:6.0.7-0ubuntu0.18.04.5 CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: x11; Locale: fr-CA (en_CA.UTF-8); Calc: group

system: Linux MInt 19.1 cinammon on a Dell inspiron 7352

edit retag flag offensive close merge delete

Comments

In which file format do you save? How are your tables anchored?

ebot gravatar imageebot ( 2019-08-15 10:58:17 +0200 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2019-08-15 09:55:15 +0200

I had the same problem. The above advice was already followed. When I copied and pasted all of the text from the offending column into a new Writer document and reformatted it, the problem was fixed when I pasted the text back into the original. It was basically caused by various breaks that had been copied in.

edit flag offensive delete link more
0

answered 2019-05-12 22:11:01 +0200

ajlittoz gravatar image

Without much information on your document/table, I can suggest two leads:

  • for your tables (with cursor inside table), check Table>Table Properties, Text Flow tab where 2 check boxes control table and row split/break

In case both boxes are checked, allowing table and row to cross page breaks, problem may come from cell contents, i.e. some attribute requires either that a paragraph should not be split or that two consecutive paragraphs should always be set on same page.

  • with the cursor in the involved paragraphs, display the style sidepane (F11) if not already there and right-click on the highlighted style name. Modify and go to Text Flow tab. In the Options section, there are 2 check boxes Do not split paragraph and Keep with next paragraph which should be unchecked to let text flow play freely.

If this does not solve your problem, edit your question with the "slanted pencil" link under your description to provide more information. Eventually attach a small anonymised file still exhibiting the issue for examination.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-05-12 20:36:37 +0200

Seen: 80 times

Last updated: Aug 15