Ask Your Question
0

LibreOffice Draw (4.0.4.2 or older) can not set spellcheck/language [closed]

asked 2013-06-21 11:51:49 +0200

MortenB0 gravatar image

updated 2015-11-02 21:52:32 +0200

Alex Kemp gravatar image

Hi,

My problem is that I can not set any language on Draw. I go to tools/setup and select the language I want for the document, but mostly none of the text frames get any language set. Pressing F7 in them gives me message "Spelling control finish" with an empty pop-down for language in background frame.

Although, on some document I have some text frames on page two who detects the selected language, but in most documents it does not.

I have had similar problems on earlier versions of Writer when I created a new document by right-clicking a folder, select New, and then Opendoument Text. Then spell-check did not work, but by starting Openoffice Writer directly with a new document it work.

Any suggestion will be helpful.

Best regards Morten

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Alex Kemp
close date 2015-11-02 21:52:46.390366

Comments

1

Thanks for suggestion manj_k. Follwing "F11 → Default → (right-click) Modify... → Font tab → Language (drop-down list)" did the trick for my document !

MortenB0 gravatar imageMortenB0 ( 2013-06-26 16:06:03 +0200 )edit

If any interest, I use Windows 7. But on my home computer with Ubuntu 13.04 exactly the same happens, and it can be fixed the same way (F11)

MortenB0 gravatar imageMortenB0 ( 2013-06-27 10:20:03 +0200 )edit

4 Answers

Sort by » oldest newest most voted
0

answered 2013-06-22 19:44:35 +0200

manj_k gravatar image

[ @ROSt52 ]

Language setting in Draw
(LibreOffice 4.0.4)

(1) You can set the default language via
F11 → Default → (right-click) Modify... → Font tab → Language (drop-down list)

draw-default

(2) You can select more languages via
menu Format → Character → Font tab → Language (drop-down list)

draw-select-language

Sample document
This iss a text 3 languages en de fr.odg

[ See also the answer (2013-06-21) by @oweng ]

edit flag offensive delete link more

Comments

For setting the language attribute in Writer:

see my answer here(2013-03-02).

manj_k gravatar imagemanj_k ( 2013-06-22 21:56:32 +0200 )edit

For Dutch spell check in v4.0.4.2:

see Bug 65994 - Dutch spell checking does not work...

manj_k gravatar imagemanj_k ( 2013-06-22 22:53:56 +0200 )edit

@manj_k - thanks for the information about fdo#65994. With this I could connect 3 bugs.

ROSt52 gravatar imageROSt52 ( 2013-06-24 05:03:27 +0200 )edit

@manj_k - let me come back to your advice above. I downloaded your sample file and regard the 2nd proposal as a very good workaround. Thanks a lot!

ROSt52 gravatar imageROSt52 ( 2013-06-27 02:46:42 +0200 )edit
0

answered 2013-06-22 18:14:38 +0200

ROSt52 gravatar image

I just migrated from 3.6.6.2 to 4.0.4.2 on XP Prof /SP3 Asian language support package installed.

In LibO I installed English US (default), Japanese, German and Dutch. In Draw, Calc and Impress I cannot select a language and in Writer there are limitations. Details in fdo#66051.

edit flag offensive delete link more

Comments

I did more testing with Dutch in Writer and found language recognition depends on the amount of text and the way text is selected. Details are in the 2nd attachment of fdo#66051.

To select Dutch for" Selection", "Paragraph, or "All text", it should help to select a longer text by cursor from top down but not include an empty line.

To me this workaround seems to be needed only if Dutch is not the default language but one of several installed languages with English as default language.

ROSt52 gravatar imageROSt52 ( 2013-06-24 05:00:45 +0200 )edit
0

answered 2013-06-21 13:52:45 +0200

oweng gravatar image

updated 2013-06-21 13:54:13 +0200

You don't mention your operating system. Are these text frames inserted via the Text button (F2) on the Drawing toolbar? If you right-click on the frame > Character... > Font tab, what is the language displayed? You will need the related language pack installed for the displayed language. Pressing F7 here (Crunchbang 11 running TDF/LO v4.0.3.3) certainly initiates the spell check on the contents of a text frame as expected, using the dictionary indicated.

I have had similar problems on earlier versions of Writer when I created a new document by right-clicking a folder, select New, and then Opendoument Text.

I would recommend avoiding this type of workflow. There are known problems with creating documents in this manner, particularly under Windows. Bug fdo#61682, for example, may be related. The best workflow for new documents is invariably to start LO and save your document to the required location.

edit flag offensive delete link more
0

answered 2013-06-21 21:26:40 +0200

manj_k gravatar image

I have had similar problems on earlier versions of Writer when I created a new document by right-clicking a folder, select New, and then OpenDocument Text.

Please have a look at the workaround in this thread:
When I'm starting program it is no language to check spelling.

See also: Questions, tagged "right-click"

edit flag offensive delete link more

Comments

Does this workaround prevent the right-click on desktop method from erroneously creating the wrong file type in some instances or is that a separate problem? I have answered some queries over on the other forum from users that are finding problems with the right-click on desktop method as well as this one here. Just want to know if I should amend my answer in this respect. Thanks.

oweng gravatar imageoweng ( 2013-06-22 01:58:08 +0200 )edit

This workaround refers to the templates (right-click, new) soffice.odt, soffice.ods, soffice.odp, soffice.odg (installed with LibreOffice).

You can edit these files, or you can replace them with any renamed template (.ott, .ots, .otp, .otg).

A short test with replacing the template (right-click, new) winword.doc (once installed with MS Word 2000; now file-type association with LO Writer) has not turned out satisfactory (e.g.: all custom styles missing, page format "Letter" instead of "A4"...

manj_k gravatar imagemanj_k ( 2013-06-22 13:05:34 +0200 )edit

... when editing: "Default Style" (and linked styles) has been modified from "Liberation Sans 11pt" to "Times New Roman 10pt", etc.). Conclusion: unusable – not the right workflow.

manj_k gravatar imagemanj_k ( 2013-06-22 13:51:24 +0200 )edit

Question Tools

2 followers

Stats

Asked: 2013-06-21 11:51:49 +0200

Seen: 1,427 times

Last updated: Jun 22 '13