Ask Your Question
0

Formulas in Writer displays weird characters

asked 2019-06-21 18:32:55 +0200

sfaucon gravatar image

updated 2019-06-22 17:37:47 +0200

Hello,

When I'm inserting a formula in Writer some characters are correct others do not make sense. For example

  • the + sign is a letter
  • Round brackets are 2 phones on each side

I would like to know how to get the normal characters. 2 images below are illustrating the problem.

Thanks

OS : Windows 10
LO : 6.2.2.2
Installed directly from the website

image description image description

edit retag flag offensive close merge delete

Comments

Have you font Open Symbols on your system? How did you install LO? Directly from LO site or through a package of your distro? To answer these questions, edit your question (don't use an answer which is reserved for a solution). Don't forget to mention your OS and LO version.

ajlittoz gravatar imageajlittoz ( 2019-06-21 21:39:12 +0200 )edit

We had a bug (tdf#76239) related to that - but it was fixed in 5.1...

Mike Kaganski gravatar imageMike Kaganski ( 2019-06-22 07:40:47 +0200 )edit

Thanks Mike and ajlittoz. It was the Open Symbols file.

sfaucon gravatar imagesfaucon ( 2019-06-22 17:42:47 +0200 )edit

I think you made a mistake when closing your question: it doesn't look like a duplicate (or else, please, mention the other AskLO question).

ajlittoz gravatar imageajlittoz ( 2019-06-22 17:52:04 +0200 )edit

@ajlittoz: You may give an answer based on your comment... Then the OQ can accept that answer . This is more informative for other users than whether the question is closed or not. Your karma should also be sufficient to reopen the question.

Lupp gravatar imageLupp ( 2019-06-22 19:00:29 +0200 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2019-06-22 21:42:56 +0200

ajlittoz gravatar image

updated 2019-06-22 22:28:45 +0200

Math component of LibreOffice requires OpenSymbol font to compose formula.

On Linux, this font is listed in the package dependencies and automatically installed if not already in the system.

Installing software on Windows is inherently different. To complicate matters, a bug referenced by @Mike Kaganski prevents smooth installation and sometimes removes OpenSymbol. Consequently, make sure OpenSymbol (in its opens___.ttf variant -- note name contains 3 underscores) is present after LO installation. If not, install it manually.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

Note: I reopened the question to be able to add this answer. @sfaucon: AskLO gurus have decided some time ago that it was no longer recommended (?) to close questions, so that they can be improved, even years after asking. However, it is still necessary to mark the question as answered so that other users know they can find a solution.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-06-21 18:32:55 +0200

Seen: 54 times

Last updated: Jun 22