Ask Your Question
0

When a user opens a base file it becomes locked as read only for other users, how do I prevent this? [closed]

asked 2013-07-03 22:37:57 +0100

Libre Lyrae gravatar image

updated 2015-11-07 12:47:51 +0100

Alex Kemp gravatar image

I have a few LibreOffice Base .odb files I created for someone and we are having problems where when one user opens and edits the file, and closes it, then it is now read-only for other users. I then have to create a copy and trash the locked file so they can use it, but then again it becomes locked to anyone else and they too end up having to make a copy. I have set permissions accordingly in the folder and file properties yet it still gets locked as soon as anyone makes a change, now only they can edit it further. It's turning out to be a major pain in the butt. The files are stored on a desktop and accessed via network by 3 other computers. We are running Ubuntu 12.04 and LibreOffice 4.0.0.3. (I cannot update to 4.0.4 due to a bug in the report builder causing it to crash). I also tested it at home with Ubuntu 13.04 and LO 4.0.1.2 and got the exact same results from my computers. I found this in ReadMe:

"File locking is enabled by default in LibreOffice. On a network that uses the Network File System protocol (NFS), the locking daemon for NFS clients must be active. To disable file locking, edit the soffice script and change the line "export SAL_ENABLE_FILE_LOCKING" to "# export SAL_ENABLE_FILE_LOCKING". If you disable file locking, the write access of a document is not restricted to the user who first opens the document. Warning: The activated file locking feature can cause problems with Solaris 2.5.1 and 2.7 used in conjunction with Linux NFS 2.0. If your system environment has these parameters, we strongly recommend that you avoid using the file locking feature. Otherwise, LibreOffice will hang when you try to open a file from a NFS mounted directory from a Linux computer."

I could not find SAL_ENABLE_FILE_LOCKING where described but I found it in etc/libreoffice and changed FILE LOCKING=auto to =no on both computers and it did not work, not only that it got an error and would not even open the forms, let alone edit anything in it.

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by Alex Kemp
close date 2015-11-07 12:48:19.402580

Comments

Isn't /etc/libreoffice a symbolic link to /opt/libreoffice or is this ububufied under Ubuntu? In /opt/libreoffice/program you should have a script soffice that is used to execute soffice.bin. The variable is in the script.

oweng gravatar imageoweng ( 2013-07-04 05:25:39 +0100 )edit

1 Answer

Sort by » oldest newest most voted
1

answered 2013-09-02 20:47:20 +0100

Libre Lyrae gravatar image

The whole problem was solved by setting up the computer that held the files as a server and logging in the other computers through the server as that main computer - now there is no file locking. Unfortunately that didn't fix every problem but it fixed that one at least.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-07-03 22:37:57 +0100

Seen: 1,905 times

Last updated: Sep 02 '13