Ask Your Question
0

Mail merge missing fields?

asked 2019-06-24 04:45:16 +0200

updated 2019-06-24 05:45:29 +0200

Version 6.2.4.2 for Windows.

When I create my label merge, some fields are missing. Here's my sample label:

Sample Label

Here are my first seven rows of the spreadsheet (that's properly tied in through a database and used as a source) for my labels:

Spreadsheet left half, seven rows Spreadsheet right half, seven rows

And here are the merged labels:

image description

How do I get the lines with empty labels to go ahead and print whether or not the labels are populated?

Thanks!

Note: I figured out the wrong association--I had "Next Record" fields in the wrong places.

edit retag flag offensive close merge delete

Comments

... and your LibreOffice version is ... ? (In recent version, this specific function was extended, so answwer depends; it's always good to state what you work with).

and apparently associated with the wrong records

Please at least mark the places where you have wrong association. While omitted lines are easy to spot, trying to track the relations between your screenshotted DB and mailmerge results is a pain, and I just decided to abandon after the second item.

Also - it's not easy to work with screenshots: the fields in them are not too handy to select and check their properties; the same about document properties as well. I suppose that attaching the mailmerge document (without the DB) would be safe enough (wrt not revealing sensitive info). If needed, sanitizing DB and providing it as well could be required.

Mike Kaganski gravatar imageMike Kaganski ( 2019-06-24 05:12:49 +0200 )edit

I just edited my question. I figured out the wrong associations. I had "Next Record" fields in the wrong places. The only thing I'm dealing with now is printing lines with empty fields.

I'm running 6.2.4.2 for Windows.

Stormsgreatkids gravatar imageStormsgreatkids ( 2019-06-24 05:49:38 +0200 )edit

In tdf#35798, we had introduced a possibility to auto-hide the paragraphs with empty records without any additional fields (since 6.1). This is controlled with a special compatibility option under OptionsLibreOffice WriterCompatibilityHide paragraphs of database fields (e.g., mail merge) with an empty value.

Mike Kaganski gravatar imageMike Kaganski ( 2019-06-24 05:59:21 +0200 )edit

Mike, that fixed it! Thank you!

Stormsgreatkids gravatar imageStormsgreatkids ( 2019-06-24 06:22:51 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-06-24 06:24:21 +0200

Mike's comment fixed it!

In tdf#35798, we had introduced a possibility to auto-hide the paragraphs with empty records without any additional fields (since 6.1). This is controlled with a special compatibility option under Options▸LibreOffice Writer▸Compatibility▸Hide paragraphs of database fields (e.g., mail merge) with an empty value.

Mike Kaganski ( 23 mins ago )

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-06-24 04:45:16 +0200

Seen: 27 times

Last updated: Jun 24