Ask Your Question
0

master document chapter numbers

asked 2019-06-25 08:34:04 +0200

BrahminyKite gravatar image

updated 2019-06-26 07:05:19 +0200

I am writing my dissertation in LibreOffice. Several chapters have already been written in separate .odt files. I am trying to use a master document to bring the chapters together and create an index. I've followed the documentation here https://help.libreoffice.org/Writer/M..., but I am not able to make the chapter numbering work correctly.

The first line in each chapter file has the Heading 1 style, which is numbered. In the master document, I add each chapter file using Insert > File. However, each Heading 1 is numbered 1. The index is of course unintelligible because it has a whole series of Chapters 1.

I ran a test with a new file, which had several paragraphs with the Heading 1 style. I used File > Send > Create Master Document. The document is split into smaller files based on Heading 1, and chapter numbering works correctly. However, this doesn't really work for me since my work is already in separate documents.

Is there any way to use my existing dissertation chapter files, all based on the same template, and import these into a master document with correct chapter numbering?

I am running Windows 10 (version 1904) and LibreOffice 6.1.6.

edit retag flag offensive close merge delete

Comments

which is numbered

how? do you use Chapter Numbering feature?

Mike Kaganski gravatar imageMike Kaganski ( 2019-06-25 09:22:57 +0200 )edit

Maybe this documentation will help you further.

You can also enter the word "Chapter" at the top of the question box.

ebot gravatar imageebot ( 2019-06-25 10:08:35 +0200 )edit

Yes, I am using the Chapter Numbering feature for all current documents that I'm trying to add to the master document.

BrahminyKite gravatar imageBrahminyKite ( 2019-06-26 07:07:31 +0200 )edit

To elaborate on @Mike Kaganski's comment, have you added manually the numbering in the Heading 1 paragraph content? Normal numbering is triggered by enabling it in Tools>Chapter Numbering and defining its properties there.

ajlittoz gravatar imageajlittoz ( 2019-06-26 08:24:47 +0200 )edit

I added the numbering for Heading 1 using Chapter Numbering in Tools > Chapter Numbering. I started over, building a document template from scratch and associating each of my 9 chapters with the new template as described in LibreOffice Writer Guide 6.0 pp 221-222. Then I created a new master document as described in Combining several documents into a master document, pp 361-363. I followed the steps exactly.

I still get the same problem, with all chapters in the master document numbered chapter 1, except, mysteriously, for chapter 4. Chapter 4 is numbered 2, apparently being set correctly to be numbered after the previous chapter. To find what was different about chapter 4, I looked in the properties of the Heading 1 style in both ch4 and another chapter, as well as in the settings in Tools > Chapter Numbering. Everything is identical as far as I can tell ...(more)

BrahminyKite gravatar imageBrahminyKite ( 2019-07-05 03:43:46 +0200 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2019-07-05 05:32:12 +0200

BrahminyKite gravatar image

It appears that the issue was with a setting in Heading 1 in all but one of the dissertation chapter documents. I solved the problem by making a new template and new chapter files, and copy/pasting all the content except heading 1, which I typed in manually.

In the master document I was getting chapter numbering as follows:

  • Chapter 1
  • Chapter 1
  • Chapter 1
  • Chapter 2
  • Chapter 1
  • Chapter 1
  • Chapter 1
  • Chapter 1
  • Chapter 1

The fourth chapter was the only one that automatically continued chapter numbering from the previous chapter, but I couldn't find any setting that was different between chapter 4 and the other chapters. So I did this:

  • Make a new document template from scratch
  • For each chapter create a new document based on the template, just typing in the chapter title and applying the Heading 1 style.
  • Open the first chapter and go to File > Send > Create Master Document.
  • For each chapter, open the old file, delete the single Heading 1 (chapter title) and copy all the rest, pasting it into the newly created chapter file, which is linked to the master document.
  • Add all the new files to the Master Document
  • Save/update.

The numbering works now.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-06-25 08:34:04 +0200

Seen: 69 times

Last updated: Jul 05