Ask Your Question
0

Images created in Draw and imported in Writer still show layers that were set as invisible and not printable.

asked 2019-06-28 11:48:42 +0200

gds gravatar image

updated 2019-06-28 14:33:44 +0200

Hello, I'm trying to create images in Draw with layers for different languages and I would like to import them into a Writer document showing only the language needed. For example, when I set Italian language as visible and English language as invisible, once I import the Draw image, Writer still shows both languages (one over the other). Not even exporting in png format the result does not change: all layer are shown. I didn't try to print the document, but I assume it would have the same issue. Is there a way to solve this problem or a workaround?

The o.s. is Windows 10 and LibreOffice is Versione: 6.2.4.2 (x64). I import my draw drawings as OLE Objects from menù Insert.

Thanks in advance, best regards. Gabriele

edit retag flag offensive close merge delete

Comments

Your description is not complete for me. Which operating system do you use? Which LO version do you use? How do you import your draw drawings? To complete your question, please edit your question. Do not answer if it is not an answer to your question. Thank you.

ebot gravatar imageebot ( 2019-06-28 12:29:51 +0200 )edit

3 Answers

Sort by » oldest newest most voted
1

answered 2019-06-28 15:16:21 +0200

RGB-es gravatar image

A normal copy/paste does not carry the invisible layer (just tried on LibO 6.2.4: uncheck "visible" on the layer properties and select/copy/paste the result). So, instead of File → Export and then insert the resulting image, just select the objects of your drawing with the mouse (also: Ctrl A will select all objects in the page) and then do the normal Ctrl C / Ctrl V.

Instead of a normal paste you can also use a "paste special → GDI Metafile" (Ctrl Shift V→ GDI Metafile) to get a vector image instead of a Draw object.

edit flag offensive delete link more
0

answered 2019-07-02 17:08:49 +0200

gds gravatar image

I tried the solution of RGB-e swith copy and paste as GDI metafile and with SVG image also. It functions very well. Thanks you. Gabriele.

edit flag offensive delete link more
0

answered 2019-06-28 13:43:04 +0200

ebot gravatar image

Thanks for your additional information.

I have tested it with me. This approach will not be successful for your needs.

You should set your drawing once for each language in Draw. You can mark your elements (objects) in each case. Select the menu File>Exporte. In the dialog box "Export" you can e.g. select the file type "*.png". And check there "Selections" and click "Save". You can then paste the PNG files into your Writer document as you like. I wish you success!

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-06-28 11:48:42 +0200

Seen: 53 times

Last updated: Jul 02