Differences between 6.1.5.2 and 6.2.4.2 LibreOffice UI

asked 2019-07-01 06:37:30 +0200

hvankampen gravatar image

updated 2019-07-04 01:49:51 +0200

I have composed a calc data entry form in LO version 6.1.5.2, Ubuntu 19.04. It works fine.

When I open the file in LO 6.1.5.2, I get a security warning screen (image 6.1.5.2-1.png). I select "Enable Macros", the file opens, and the data entry form appears (image 6.1.5.2-2.png), and all is well.

When I open the file in LO 6.2.4.2, the security screen appears (image 6.2.4.2-1.png). Note the different appearance compared to 6.1.5.2-1.png. I select "Enable Macros" and the data entry form appears (image 6.2.4.2-2.png). Again, note the different appearance compared to 6.1.5.2-2.png. When the file is opened in 6.2.4.2, I notice the following (a not complete list):

1: The overall size of the data entry screen is larger than in 6.1.5.2. 2: The font of the field labels is gray rather than black. 3: The command buttons along the bottom are a different size and the background color is white rather than gray. 4: The text fields have a "flat" appearance, rather than a "3D look" as specified in the properties list pane.

I don't believe this is a problem only with my files, as I also note that when I open a new file, enter the "LibreOffice Basic" screen, insert a dialog and add a textbox, the properties list pane looks different between 6.1.5.2 and 6.2.4.2 (images 6.1.5.2-3.png and 6.2.4.2-3.png).

Also, the differences are obvious in the "Browse Records" screen (images 6.1.5.2-4.png and 6.2.4.2-4.png.

Can anyone tell me why are the screen renderings different? Has there been some change to the LibreOffice Basic layout and functionality?

Thanks for any info.

6.1.5.2-1.png 6.1.5.2-2.png 6.1.5.2-3.png 6.1.5.2-4.png 6.2.4.2-1.png 6.2.4.2-2.png 6,2,4,2-3.png 6.2.4.2-4.png

edit retag flag offensive close merge delete

Comments

... and complete contents of Help->About for each version are ...? :-)

Mike Kaganski gravatar imageMike Kaganski ( 2019-07-01 06:42:21 +0200 )edit

The info for 6.1.5.2 is: Version: 6.1.5.2 Build ID: 90f8dcf33c87b3705e78202e3df5142b201bd805 CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: x11; Locale: en-CA (en_CA.UTF-8); Calc: group threaded

The info for 6.2.4.2 is: Version: 6.2.4.2 Build ID: 2412653d852ce75f65fbfa83fb7e7b669a126d64 CPU threads: 4; OS: Linux 5.0; UI render: default; VCL: gtk3; Locale: en-CA (en_CA.UTF-8); UI-Language: en-US

hvankampen gravatar imagehvankampen ( 2019-07-01 14:08:07 +0200 )edit

Aha, that explains. Your 6.1.5.2 uses VCL: x11, while 6.2.4.2 uses VCL: gtk3, giving a different (more native for gtk) look and feel.

Mike Kaganski gravatar imageMike Kaganski ( 2019-07-01 14:10:32 +0200 )edit

I also note the the format of the "About" screens shows the same variances as in the "Enable Macros" screen.

hvankampen gravatar imagehvankampen ( 2019-07-01 14:10:42 +0200 )edit

heh, the whole LibreOffice looks different, not only a couple of dialogs :-)

Mike Kaganski gravatar imageMike Kaganski ( 2019-07-01 14:18:28 +0200 )edit

Indeed. Any suggestions on how to resolve this issue?

Thanks in advance.

hvankampen gravatar imagehvankampen ( 2019-07-01 15:13:39 +0200 )edit

This is not an issue. LibreOffice may be integrated into many environments, and it aims to look native. The integration is done using VCL plugins. In your case, older version used generic plugin, not providing native experience in gtk environment (for unclear reasons). Your newer version uses proper plugin. You are, of course, free to use generic plugin there, too, and call that "solution", but better get used to this look and feel.

Mike Kaganski gravatar imageMike Kaganski ( 2019-07-01 15:18:59 +0200 )edit

Thanks for the info. I cannot seem to find where to change the environment variables your link refers to. Help would be appreciated. There is another issue: If I go into the Basic editor and change, say, the height of a textbox or its background color, when I run the macro the change is not reflected in the displayed userform, though if I change the width, it is. So, modifying the userform is problematic.

hvankampen gravatar imagehvankampen ( 2019-07-01 16:28:33 +0200 )edit

For testing, you can always set the variable directly, like running this in terminal:

> SAL_USE_VCLPLUGIN=gen soffice

To make long-term setting, you need to put it somewhere into session configuration file, like ~/.profile.

Mike Kaganski gravatar imageMike Kaganski ( 2019-07-01 16:51:08 +0200 )edit

Why are you doing these "updates" to the message? Are you bumping it?

Mike Kaganski gravatar imageMike Kaganski ( 2019-07-04 04:18:00 +0200 )edit