Ask Your Question
0

English UK dictionary spelling error

asked 2019-07-05 18:38:56 +0200

Muttley gravatar image

Hello. I've recently swapped over from Microsoft Office, I've checked and rechecked my settings to ensure that the language is 'English UK' in Writer, 'for selection,' 'for paragraph' and 'for all text.' English UK is also my default for LibreOffice.

I've unticked English USA

So my question is why am I still getting 'English American' spellings for example 'realize' instead of 'realise,' 'color,' instead of 'colour,' this is very annoying as I can use both spellings and both are deemed correct in the document.

Please advise.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
1

answered 2019-07-05 18:59:44 +0200

ajlittoz gravatar image

updated 2019-07-13 15:30:29 +0200

You're probably under Windows. Under Linux, English variants beyond en_US are provided by a separate "language pack" which must be explicitly installed (like any other language pack). See if such a language pack exists under Windows (I don't know which file type it might look like) and verify it is installed. Otherwise install it.

Regarding default language for documents, I wouldn't recommend Tools>Language>For … because this is a manual step and you might forget it in a future document. Rather, go to Tools>Options, Language settings>Language and define it there. This setting is kept in user profile and will be automatically chosen next time you open LO Writer. This works provided you didn't already change language setting in paragraph style Default Style. In the latter case, remove your custom setting with button Reset or set your preferred language. If you set it in Default Style, any change in Tools>Options, Language Settings>Language will be barred by your modification in Default Style.

To show the community your question has been answered, click the ✓ next to the correct answer, and "upvote" by clicking on the ^ arrow of any helpful answers. These are the mechanisms for communicating the quality of the Q&A on this site. Thanks!

EDIT 2019-07-13 (after your comment)

Default language for documents is set through Tools>Options, Language Settings>Languages as I previously mentioned. I forgot to mention additional settings in Tools>Options, Language Settings>Writing Aids: this is where you enable the dictionaries. Check that en_GB is in the list.

As you say misspellings are always possible. Eventually, make a list of them and report as a bug.

edit flag offensive delete link more

Comments

Hello 'ajlittoz's' Thank you for your reply.

Operating System. I have Windows 10, it's default setting in region & language are as follows: Country, 'United Kingdom.' Languages, Windows display language,'English (United Kingdom).' Preferred languages 'English (United Kingdom)' Just in case I also checked in Administrative language settings. Formats, 'match display language (recommended)'

In LibreOffice I had already downloaded the English dictionary pack, just in case of a download error and ensured that English UK is the default. The pack claims to include 'English UK.' unfortunately it also contains all of the different English dictionaries too. I had already reset LibreOffice which fixed another problem I was experiencing before this posting, but it didn't fix the USA/UK spelling errors. The thing is, some words are noticed as misspelled using English American, while others are not, so perhaps who ever created the UK dictionary missed a few.

Muttley gravatar imageMuttley ( 2019-07-13 14:48:02 +0200 )edit

Hunspell dictionaries are plain-text files, so, you can simply remove unwanted entries using a text editor. And if you report issues to the dictionary author(s)/maintainer(s), your help will be appreciated, I think (contact details should be available in the readme file or some other accompanying documentation). As I understand, the UK dictionary was derived from the US dictionary, so, some US stuff may remain indeed.

gabix gravatar imagegabix ( 2019-07-13 15:56:16 +0200 )edit
0

answered 2019-07-13 16:11:40 +0200

Hello!

I am the British speller maintainer.

It works as expected: https://i.imgur.com/E9q2ZTK.png

"color" appears as a typo and "realise" can both be written with -ize/-ise.

Have you tried to change all your text to British?: Tools → Language → For all text → English (UK)

Also, here is more detailed information regarding the spellers: http://proofingtoolgui.org/en_install...

I hope this helps.

edit flag offensive delete link more
Login/Signup to Answer

Question Tools

2 followers

Stats

Asked: 2019-07-05 18:38:56 +0200

Seen: 36 times

Last updated: Jul 13