Ask Your Question
0

Is there a way to edit the list of words in the AutoText feature in Writer.

asked 2019-07-10 18:09:03 +0200

daniels gravatar image

There are a few words that I wish to remove from the AutoText word list in libre Writer. They are misspellings or partial words. Is there a way to open the AutoText list of words to edit it or to remove words I do not wish AutoText to handle.

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2019-07-22 08:19:33 +0200

gabix gravatar image

A kinda kill-'em-all solution: just delete all files from the /autocorr and /autotext subdirectories in your user profile.

edit flag offensive delete link more

Comments

I found that deleting all files makes LibO crash after a short time. So I kept

~/.config/libreoffice/4/user/autotext/mytexts.bau

which does not contain anything, this way it works.

Do we agree that at present there are no controls in the GUI to disable or edit AutoText? - I think this is bad especially in the case you use a system wide auto text generator like "AutoKey", because both are likely to interfere. I'd file a bug report in that case.

herrdeh gravatar imageherrdeh ( 2019-07-23 06:35:26 +0200 )edit

Why, Format → AutoCorrect → While typing to enable/disable, Format → AutoCorrect → AutoCorrrect Options to change. Maybe, not the best design, but I can't imagine something better. Or what do you mean?

gabix gravatar imagegabix ( 2019-07-23 08:20:56 +0200 )edit

As far as I understood, AutoCorrect and AutoText are two different features. I'm happy with AutoCorrect, there is the control "AutoCorrect options" where I can add and edit AutoCorrect items.

This does not work for me with AutoText - as far as I found out till now.

herrdeh gravatar imageherrdeh ( 2019-07-24 13:02:55 +0200 )edit
1

answered 2019-07-11 04:22:18 +0200

robleyd gravatar image

updated 2019-07-11 05:38:13 +0200

You can edit AutoText entries by going to Tools | Autotext (Ctrl+F3) and select the entry you want to modify; then use the dropdown list under the AutoText button at the bottom of the dialog.

But you may be talking about the AutoCorrect function; you can also change that via Tools | AutoCorrect | AutoCorrect Options.

If this answer helped you, please accept it by clicking the check mark ✔ to the left and, karma permitting, upvote it. That will help other people with the same question.

edit flag offensive delete link more

Comments

This does not work for me - the "AutoText" dropdown list at the bottom is grayed out.

Version: 6.2.4.2 Build-ID: 1:6.2.4-0ubuntu0.18.04.1~lo1 CPU-Threads: 8; BS: Linux 4.15; UI-Render: Standard; VCL: gtk3; Gebietsschema: de-DE (de_DE.UTF-8); UI-Sprache: de-DE

herrdeh gravatar imageherrdeh ( 2019-07-22 10:19:12 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-07-10 18:09:03 +0200

Seen: 37 times

Last updated: Jul 22