Ask Your Question
0

Does Update 6.2.5.2 (86) remove NetFramework 4.0.3

asked 2019-07-17 11:13:12 +0200

voxmagna gravatar image

Hi, I've worked hard to get a Win7 pc error free using Event Viewer and realized early on I needed several versions of MS NetFramework for some of my older apps to work. Some need the specific version and don't work with later versions claimed to be backwards compatible. This seems to happen with older applications no longer supported or updated by the original author.

So I install 6.2.5.2 over my previous version and Win7 errors on no NetFramework version 4.0.3 which I go back and install. Does LibrOffice use MS NetFramework, which versions and does it remove a previous version when it updates?

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
0

answered 2019-07-17 11:41:01 +0200

LibreOffice does not use .Net framework, and doesn't include (nor requires, nor uses) any installer of it (although it includes CLI libraries that are usable by those who want to write applications using LibreOffice). The problem with missing .Net you are facing is not common, and is likely being a coincidence, or a result of your convoluted setup.

edit flag offensive delete link more
0

answered 2019-07-17 11:29:19 +0200

voxmagna gravatar image

Now a second question plea to software writers: I always change the default file locations to another little used hard drive where I can guarantee latest settings and docs will be there if and when Win7_64 crashes. By default LO uses the Windows protected file locations. I don't think Win7 was always like that, but it certainly is after doing the MS updates.

Using these file locations Win7 issues an Event error 1000 during Boot but it doesn't crash the app. After an update, LO reset my custom file paths back to clean install default locations in the Windows system area and gave event error 1000 each Boot. After modifying the file paths for backups etc to my other drive, there were no startup errors.My LO is not set for fast startup and shouldn't be doing much during boot, although it seems to be accessing the windows file locations used for system and app data files?

My plea to LO software writers is can updates within the same version please capture and restore my file path and any other configurations I have set on the previous version?

edit flag offensive delete link more

Comments

Please do not use "Your Answer" if you don't actually answer a question but commenting an answer. Please use "add a comment" for that purpose or edit your question, if you are adding additional information. Thanks in advance ...

And if you have an enhancement request, than this site is not the right place to address your request. Use this one

Opaque gravatar imageOpaque ( 2019-07-17 11:36:39 +0200 )edit
  1. Please don't use "answer" for what doesn't answer original question. If you want to clarify your question, you should edit the question itself.
  2. In this specific case, your "answer" isn't related to the first - i this case, please don't mix several questions in one topic. Post each question separately.

So please remove the "answer" and re-post as separate question. Thanks.

Mike Kaganski gravatar imageMike Kaganski ( 2019-07-17 11:37:25 +0200 )edit
Login/Signup to Answer

Question Tools

1 follower

Stats

Asked: 2019-07-17 11:13:12 +0200

Seen: 30 times

Last updated: Jul 17